DetailPage-MSS-KB

Base de Dados de Conhecimento

Artigo: 262381 - Última revisão: sábado, 27 de Janeiro de 2007 - Revisão: 2.4

 

Nesta página

Sintomas

Quando tenta instalar o Windows 98 ou Windows Millennium Edition (Me), programa de configuração poderá deixar de responder (não reagir) durante o processo de detecção de hardware. Durante esta fase, o programa de configuração determina que componentes de hardware são instalados no computador. Esta fase requer que reinicie o computador uma ou duas vezes, dependendo do tipo de hardware no computador. Pode identificar esta fase do programa de configuração, o ecrã "Configurar hardware".

Causa

O computador poderá deixar de responder devido a vários problemas de hardware. Se estiver a tentar actualizar, este comportamento pode ocorrer devido a conflitos com as definições de hardware anteriores. Se está a tentar instalar uma versão completa do Windows 98 ou Windows Me, este comportamento pode ocorrer devido a hardware incompatível, o hardware que está localizado na ranhura bus errada na placa principal ou definições do BIOS (Basic Input/Output System).

Resolução

Nota Uma vez que existem várias versões do Microsoft Windows, os seguintes passos podem ser diferentes no computador. Se forem, consulte a documentação do produto para concluir estes passos.

Para resolver este problema, efectue um dos seguintes métodos de resolução de problemas:

Reinicie o computador

Poderá conseguir resolver este problema reiniciando o computador. Desligue o computador e, em seguida, voltar a activá-lo. Se o programa de configuração do Windows 98 nao continuar, tente o método seguinte.


Reiniciar no modo de segurança e utilizar o Msconfig.exe

Reinicie o computador, prima e mantenha premida a tecla CTRL depois do computador concluir o procedimento POST (Power On Self Test) e seleccione Modo de segurança no menu de arranque . Para obter informações adicionais sobre o arranque do Windows 98, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
178548  (http://support.microsoft.com/kb/178548/EN-US/ ) Sem mensagem 'A iniciar o Windows 98' no arranque
Depois do computador ser reiniciado em modo de segurança, utilize a ferramenta Utilitário de configuração do sistema (Msconfig.exe) para minimizar conflitos que poderão impedir que o computador a partir de concluir o programa de configuração.

Para iniciar e utilizar a ferramenta informações de sistema:
  1. Clique em Iniciar , aponte para programas , aponte para Acessórios , aponte para Ferramentas do sistema e, em seguida, clique em Informações de sistema .
  2. No menu Ferramentas , clique em Utilitário de configuração do sistema .
  3. No separador Geral , clique em Arranque selectivo (Selective Startup) e, em seguida, clique para desmarcar as seguintes caixas de verificação:
    • ficheiro Config.sys processo
    • ficheiro Autoexec.bat processo
    • O ficheiro Winstart.bat processo (se disponível)
    • ficheiro System.ini processo
    • ficheiro Win.ini processo
    • carregar arranque itens no grupo

  4. Clique em OK e reinicie o computador quando lhe for pedido.
Se programa de configuração terminar, utilize os seguintes passos para repor o computador para um modo de arranque normal. Se o computador continuar a deixar de responder (não reagir), utilize os passos na secção "Verificar a configuração de hardware".
  1. Execute utilitário de configuração do sistema, clique para seleccionar um item de arranque selectivo, clique em OK e, em seguida, siga as instruções apresentadas no ecrã para reiniciar o computador e testar não reage ou comportamento estranho.
  2. Continue este processo até que todos os itens de arranque selectivo estão seleccionados. Se seleccionar um item e o computador deixa de responder ou comporta-se invulgarmente, clique no separador para o item correspondente, limpar metade das caixas de verificação, clique em OK e, em seguida, reinicie o computador. Continue este processo até localizar a definição que está a causar o problema.
  3. Se pode reiniciar o computador com êxito quando todos os itens são seleccionados, execute utilitário de configuração do sistema, clique para seleccionar a caixa de verificação Arranque Normal , clique em OK e, em seguida, siga os passos no ecrã para reiniciar o computador.
Para obter informações adicionais sobre como utilizar o Msconfig.exe, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
192926  (http://support.microsoft.com/kb/192926/EN-US/ ) Como efectuar a resolução de problemas com arranque limpo para o Windows 98

Avançadas de resolução de problemas com Msconfig.exe

Reiniciar o computador, prima e mantenha premida a tecla CTRL depois do computador concluir o procedimento POST (Power On Self Test) e, em seguida, seleccione Modo de segurança no menu de arranque. Para obter informações adicionais sobre o arranque do Windows 98, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
178548  (http://support.microsoft.com/kb/178548/EN-US/ ) Sem mensagem 'A iniciar o Windows 98' no arranque
Depois de reiniciar o computador em modo de segurança, utilize a ferramenta Utilitário de configuração do sistema (Msconfig.exe) para minimizar conflitos que podem impedir que o computador concluir o programa de configuração.

Para iniciar e utilizar a ferramenta informações de sistema:
  1. Na barra de ferramentas clique em Iniciar , aponte para programas , aponte para Acessórios , aponte para Ferramentas do sistema e, em seguida, clique na ferramenta Informações de sistema .
  2. No menu Ferramentas , clique em Utilitário de configuração do sistema .
  3. No separador Geral , clique no Botão Avançadas .
  4. Seleccione o disco de modo de compatibilidade Force Access opção.
  5. Na parte inferior das definições Avançadas de resolução de problemas , clique em OK e, em seguida, clique novamente em OK .
  6. Reinicie o computador quando lhe for pedido.
Se a conclusão do programa de configuração, o comportamento era causado por uma incompatibilidade entre o controlador de disco rígido e o programa de configuração. No ambiente de trabalho para activar o acesso a disco de 32 bits, siga estes passos:
  1. Na barra de ferramentas clique em Iniciar , aponte para programas , aponte para Acessórios , aponte para Ferramentas do sistema e, em seguida, clique na ferramenta Informações de sistema .
  2. No menu Ferramentas , clique em Utilitário de configuração do sistema .
  3. No separador Geral , clique no Botão Avançadas .
  4. Seleccione o disco de modo de compatibilidade Force Access opção.
  5. Com as definições Avançadas de resolução de problemas , clique em OK .
  6. Reinicie o computador quando lhe for pedido.

Verifique a configuração de hardware

Para verificar a configuração de hardware no computador, reinicie o computador no modo de segurança e utilize o Gestor de dispositivos para resolver problemas de hardware instalado. Para efectuar este procedimento:
  1. Clique em Iniciar , aponte para definições , clique em Painel de controlo e, em seguida, faça duplo clique em sistema .
  2. No separador Gestor de dispositivos , desactive todos os dispositivos nos seguintes ramos:
    • Placas gráficas
    • Controladores de disquetes
    • Controladores de disco rígido
    • Teclado
    • Placas de rede
    • Socket PCMCIA
    • Portas
    • Controladores SCSI
    • Controladores de som, vídeo e jogos
    • Rato

    Para desactivar um dispositivo no Gestor de dispositivos, utilize os seguintes passos.

    Nota : Se tiver um rato série e desactivar as portas, se o Windows escreve novamente o BIOS que as portas estão desactivadas, terá que não a funcionalidade rato até activar novamente as portas no BIOS.

    1. Faça duplo clique no ramo que contém o dispositivo que pretende, clique no dispositivo e, em seguida, clique em Propriedades .
    2. No separador Geral , clique para seleccionar a caixa de verificação Desactivar neste perfil de hardware e, em seguida, clique em OK .
    3. Reinicie o computador.
    Nota : quando desactivar o rato e, em seguida, reinicie o computador, poderá receber a seguinte mensagem:
    O Windows não detectou um rato ligado ao computador. Com segurança, poderá ligar um rato série agora.
    Para activar o rato, utilize os seguintes comandos de teclado:

    1. Prima CTL, Certificate Trust List + ESC para activar o menu Iniciar .
    2. Prima seta para cima até definições estiver seleccionada, prima a seta da direita para seleccionar Painel de controlo e, em seguida, prima ENTER.
    3. Prima seta para baixo e seta esquerda até sistema está seleccionada e, em seguida, prima ENTER.
    4. Prima para a direita para seleccionar o separador Gestor de dispositivos , prima a tecla TAB, prima a tecla TAB e, em seguida, prima SETA para baixo para seleccionar o dispositivo listado no ramo expandido rato .
    5. Prima a tecla TAB para seleccionar Propriedades , prima ENTER, prima TAB para seleccionar Activar o dispositivo e, em seguida, prima ENTER.
    6. Clique em OK e clique em ' Sim ' para reiniciar o computador.
    7. Se o rato ainda não funcionar após o passo E, prima TAB e, em seguida, prima ENTER. Prima ENTER quando receber o pedido para reiniciar o computador.
  3. Se continuar o programa de configuração, Active os dispositivos que desactivou no passo 2 após configuração estiver concluída, e verifique se que não existem dispositivos em conflito. Active os dispositivos pela seguinte ordem:
    • Portas COM
    • Controladores de disco rígido
    • Controladores de disquetes
    • Todos os outros dispositivos

    Para activar um dispositivo e verificar a existência de possíveis conflitos, siga estes passos:

    1. Faça duplo clique no ramo que contém o dispositivo que pretende, clique no dispositivo e, em seguida, clique em Propriedades .
    2. No separador Geral , clique para desmarcar a caixa de verificação Desactivar neste perfil de hardware .
    3. No separador recursos , verifique se existem conflitos listados na caixa de Lista de dispositivos em conflito . Repare que o separador recursos não é apresentado para cada dispositivo.
    4. Clique em OK e, em seguida, reinicie o computador.

Verificar os ficheiros de registo

Outro método de resolução de problemas que poderão ajudar a determinar a causa do problema é examinar os ficheiros de registo de configuração. Três ficheiros são criados durante o programa de configuração:
  • Detlog.txt. Este ficheiro de registo apresenta o início do teste de detecção e o resultado do teste. Este é um ficheiro oculto localizado na pasta raiz da unidade C.
  • Detcrash.log. Este ficheiro regista a detecção passos foram concluídos com êxito para que o programa de configuração não pendurar no mesmo passo novamente. Este é um ficheiro oculto que é criado apenas se o passo de detecção causou o computador deixar de responder. Este ficheiro está localizado na pasta raiz da unidade C.
  • Setuplog.txt. Este ficheiro regista o que é efectuada durante a configuração, incluindo êxitos e problemas. É utilizado pela recuperação de segurança para determinar onde o programa de configuração deverá continuar. Este ficheiro está localizado na pasta raiz da unidade C.

Instalar uma nova pasta

Se o problema persistir, instale o Windows numa nova pasta para fins de teste. Pode utilizar o comando seguinte do programa de configuração para resolver um módulo específico:
o programa de configuração /p b
O parâmetro /p faz com que programa de configuração passar directamente para detecção Gestor (Sysdetmg.dll) de cadeias. O programa de configuração não interpreta o conteúdo da cadeia. A cadeia pode conter uma ou mais opções de detecção.

O parâmetro b activa o modo perguntar antes. Pede-lhe antes de um módulo de detecção é chamado para que possa avançar manualmente cada módulo de detecção e decidir se pretende ignorá-lo. A predefinição é desactivado.

Para obter informações adicionais sobre como instalar Windows 98 numa nova pasta, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
193902  (http://support.microsoft.com/kb/193902/EN-US/ ) Como instalar o Windows 98 para uma nova pasta

Verificar existência de problemas de sistema (BIOS) de entrada/saída básico

Em determinadas placas principais, Windows 98 ou Windows Me não conseguir concluir com êxito a detecção de Plug and Play processar. Este problema pode dever-se uma interpretação incorrecta dos dados armazenados no BIOS do computador. Se tiver tentado os passos descritos os métodos anteriores e o computador ainda não reage durante a detecção de hardware, contacte o fabricante do computador para ver se necessita de uma actualização antes de instalar Windows 98 no computador.

Actualização sobre o Windows 3.1

Se estiver a actualizar a partir do Microsoft Windows 3.1, poderá ter um ficheiro de grupo (Zip) do Windows 3.1 danificado. Se tiver um ficheiro de grupo danificado, utilize a ferramenta conversor do grupo para recriar os grupos. Para o fazer, utilize os seguintes passos:
  1. Desactive o computador para, pelo menos, dez segundos e, em seguida, voltar a activá-lo.
  2. Clique em Iniciar , clique em Executar , escreva grpconv.exe na caixa Abrir e, em seguida, clique em OK .

Utilizar o Novell IntraNetWare cliente versão 2.2

Se estiver a actualizar a partir do Windows 95 com o Novell IntraNetWare Client versão 2.2 para o Windows 95 instalado software (também conhecido como Client32), contactar a Novell sobre como obter um ficheiro Nwsipx32.dll actualizado.

Os produtos de outros fabricantes que são discutidos neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não oferece nenhuma garantia, expressa ou implícita, relativamente ao desempenho ou fiabilidade destes produtos.

Mais Informação

Para obter informações adicionais sobre problemas hardware após a conclusão do programa de configuração, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
133240  (http://support.microsoft.com/kb/133240/EN-US/ ) Resolução de problemas de conflitos de dispositivos com o ' Gestor de dispositivos '

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Segunda Edição
  • Microsoft Windows 98 Standard Edition
Palavras-chave: 
kbmt kbenv kbhardware kbprb kbsetup kbtshoot KB262381 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 262381  (http://support.microsoft.com/kb/262381/en-us/ )
Partilhar
Opções de suporte adicionais
Fóruns de Suporte da Comunidade Microsoft
Contacte-nos directamente
Encontre um parceiro certificado Microsoft
Loja Microsoft