DetailPage-MSS-KB

Base de Dados de Conhecimento

Artigo: 2666484 - Última revisão: sexta-feira, 16 de Março de 2012 - Revisão: 1.0

Disponível transferência de hotfix
Ver e solicitar transferências de hotfix
 
 

Nesta página

Sintomas

Suponha que você tenha vários servidores Host de sessão de área de trabalho remota (RD) baseado no Windows Server 2008 R2 que usam um agente de conexão de área de trabalho remota para equilibrar as conexões de área de trabalho remota. Nessa situação, você recebe aleatoriamente uma mensagem de erro Stop semelhante à seguinte nos servidores Host de sessão de RD:
STOP: 0X0000003B (Parameter1, Parâmetro2, Parâmetro3, Parâmetro4)
SYSTEM_SERVICE_EXCEPTION
Observações
  • Nem todos os erros de parada "0x0000003B" são causados pelo problema.
  • Os parâmetros nessa mensagem de erro Stop podem variar, dependendo da configuração do computador.

Causa

Esse problema ocorre porque o módulo de DLL passa uma variável null para outras funções incorretamente.

Resolução

Para resolver esse problema, instale o hotfix nos servidores Host de sessão de RD baseado no Windows Server 2008 R2.

Informações sobre hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplica esse hotfix somente aos sistemas que apresentarem o problema descrito neste artigo. Este hotfix pode receber testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não for exibida, contate o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos de suporte normais se aplicarão a perguntas de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa dos números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve estar executando o Windows Server 2008 R2 ou Windows Server 2008 R2 Service Pack 1 (SP1). Além disso, o serviço de função Host de sessão de área de trabalho remota deve ser instalado no servidor.

Para obter mais informações sobre como obter um service pack do Windows 7 ou Windows Server 2008 R2, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
976932  (http://support.microsoft.com/kb/976932/ ) Informações sobre o Service Pack 1 para Windows 7 e Windows Server 2008 R2

Informações do registro

Para aplicar esse hotfix, não é necessário fazer alterações no registro.

Requisito de reinicialização

Você deve reiniciar o computador após aplicar esse hotfix.Para evitar a reinicialização do computador, pare o serviço de função Host de sessão RD antes de aplicar o hotfix.

Informações de substituição do hotfix

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações do arquivo

A versão global deste hotfix instala arquivos que tenham os atributos listados nas tabelas a seguir. As datas e horários para esses arquivos estão listados no tempo Universal Coordenado (UTC). As datas e horários para esses arquivos no computador local são exibidos em sua hora local com a diferença de horário de verão (DST) atual. Além disso, as datas e horas podem ser alterados quando você realizar algumas operações nos arquivos.
Observações das informações de arquivo do Windows Server 2008 R2
  • Os arquivos que se aplicam a um produto específico, etapa (RTM, SPn), e ramificação do serviço (LDR, GDR) pode ser identificada ao examinar os números de versão do arquivo conforme mostrado na tabela a seguir:
    Reduzir esta tabelaExpandir esta tabela
    VersãoProdutoEtapa do projetoRamificação do serviço
    6.1.760 0.21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows Server 2008 R2SP1LDR
  • Os arquivos MANIFEST (. manifest) e os arquivos MUM (. mum) instalados para cada ambiente são listados separadamente na seção "informações de arquivo adicionais para o Windows Server 2008 R2". MUM e arquivos de MANIFESTO e os arquivos de catálogo (. cat) de segurança associadas, são extremamente importantes para manter o estado dos componentes atualizados. Os arquivos de catálogo de segurança para o qual os atributos não estiverem listados, são assinados com uma assinatura digital da Microsoft.
Para todas as versões baseadas em x64 do Windows Server 2008 R2
Reduzir esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Rdpwd. sys6.1.7600.21149205,82411-Fev-201204: 50x64
DLL6.1.7600.21149194.56011-Fev-201204: 50x64
DLL6.1.7601.21921274,94411-Fev-201204: 48x64

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informação

Para obter mais informações sobre a terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft

Informações de arquivo adicionais

Informações de arquivo adicionais para o Windows Server 2008 R2

Arquivos adicionais para todas as versões baseadas em x64 do Windows Server 2008 R2
Reduzir esta tabelaExpandir esta tabela
Nome de arquivoAmd64_microsoft-windows-t...DP winstationdriver_31bf3856ad364e35_6.1.7600.21149_none_a8233b1807ad468f.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo3,435
Data (UTC)11-Fev-2012
Hora (UTC)07: 03
PlataformaNão aplicável
Nome de arquivoAmd64_microsoft-windows-t...s-rdp-displaydriver_31bf3856ad364e35_6.1.7600.21149_none_413987c387a3aee1.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo2,816
Data (UTC)11-Fev-2012
Hora (UTC)07: 09
PlataformaNão aplicável
Nome de arquivoAmd64_microsoft-windows-t...s-rdp-displaydriver_31bf3856ad364e35_6.1.7601.21921_none_432dac1584c0e218.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo2,816
Data (UTC)11-Fev-2012
Hora (UTC)06: 57
PlataformaNão aplicável

A informação contida neste artigo aplica-se a:
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
Palavras-chave: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbmt KB2666484 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 2666484  (http://support.microsoft.com/kb/2666484/en-us/ )
Partilhar
Opções de suporte adicionais
Fóruns de Suporte da Comunidade Microsoft
Contacte-nos directamente
Encontre um parceiro certificado Microsoft
Loja Microsoft