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Article ID: 2802799 - Last Review: March 19, 2013 - Revision: 2.0

Symptoms

Consider the following scenario:
  • You have a PC with Windows 8 installed on it.
  • You have an Intel graphics adapter on the PC and are using the Windows 8 in-box display driver for it.
  • You have your display set to resolution that is greater than 2048x1152.
In this scenario you may see a flickering bar stretched across approximately one-third of the screen, rendering the display unusable.


Cause

This is caused by a problem with the version of the Intel driver that was included in Windows 8.


Resolution

To resolve this issue, update the Intel display driver to a newer version that does not exhibit the described behavior. Before updating the driver, you will first need to get the PC into a usable state by following the steps below: 
  1. Force the PC to boot into Automatic Recovery Mode.
    1. If the PC is in the state with the unusable display, press and hold the power button until the PC powers off.
    2. Power on the PC. As soon as the Windows or PC manufacturer logo appears and the spinning circle is displayed, press and hold the power button to power off the PC.
    3. Repeat Step B until you see the words "Preparing Automatic Repair" appear below the logo. Allow the PC to then boot in to the Windows Recovery Environment.
    4. If after the "Preparing Automatic Repair" you see "Diagnosing your PC" appear next, continue with this step. Otherwise, continue on to Step 2. After the diagnosis step completes, you will see a screen titled "Automatic Repair". If you see the option "Advanced options", choose it and continue to Step 2. If you only see available options of "Restore" or "Cancel", choose "Cancel". At this point a logo will be displayed again. The logo may be displayed for an extended period of time with no progress indicator. After a while, the "Automatic Repair" screen with the "Shutdown" and "Advanced options" will be shown. Select "Advanced options" and continue to Step 2.
  2. Select "Troubleshoot".
  3. Select "Advanced options".
  4. Select "Startup Settings".
  5. Select "Restart".
  6. Select option 3 - "Enable low-resolution video".
The PC will then boot in to low resolution mode. You should be able to log on and use the PC at the lower resolution. If this problem occurred while installing Windows 8, Windows will continue booting into OOBE (Out of Box Experience).

Note: It may be difficult to navigate Windows using the lower resolution when the PC boots into low resolution mode. If this is the case, the display resolution can be increased via the Control Panel Display applet as long as the resolution does not exceed 2048x1152 pixels.

Now that the PC is in a usable state, the Intel graphics driver can now be updated. Steps have been provided below for obtaining an updated driver for PCs that are connected to the Internet as well as those that do not have an Internet connection.


Internet Connection:
  1. Verify Internet connectivity.
  2. Open Device Manager. For Windows 8, you can search for Device Manager by typing it in while at the Windows 8 Start screen.
  3. Expand the category Display Adapters.
  4. Double-click (or press Enter) on the Intel display adapter (for example, "Intel HD Graphics 4000 (Microsoft Corporation - WDDM 1.1)").
  5. Select "Update Driver Software".
  6. Select "Search automatically for updated driver software".

No Internet Connection:
  1. From an Internet connected PC, download the latest Intel display driver for your PC's graphics hardware from Intel's website.
  2. Save the installer package (should be a .exe file) that you downloaded to removable media such as a USB flash drive. Alternately, you could burn the file to a CD or DVD.
  3. Insert the removable media into the PC experiencing the problem.
  4. Run the installer package on the PC and follow the instructions to install the latest Intel graphics driver.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use (http://go.microsoft.com/fwlink/?LinkId=151500) for other considerations.

Applies to
  • Windows 8
  • Windows 8 N
  • Windows 8 Pro
  • Windows 8 Pro N
  • Windows 8 Enterprise
  • Windows 8 Enterprise N
Keywords: 
KB2802799
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