DetailPage-MSS-KB

Base de Dados de Conhecimento

Artigo: 825576 - Última revisão: quinta-feira, 27 de Julho de 2006 - Revisão: 5.4

 

Nesta página

Sumário

Este artigo descreve vários métodos que pode utilizar para minimizar metadados em documentos do Word.

Quando criar, abrir ou guardar um documento no Microsoft Office Word 2003, o documento poderá incluir conteúdo que não pretende partilhar com outros utilizadores ao distribuir o documento electronicamente. Estas informações são conhecidas como metadados. Os metadados são utilizados para uma variedade de finalidades para melhorar a edição, visualização, arquivo e obtenção de documentos do Office.

Alguns metadados são facilmente acessíveis através da interface de utilizador do Word. Outros metadados só são acessíveis através de meios extraordinários, como, por exemplo, abrindo um documento num editor de ficheiros binários de baixo nível. Seguem-se alguns exemplos de metadados que poderão ser armazenados nos documentos:
  • O nome
  • As suas iniciais
  • O nome da empresa ou organização
  • O nome do computador
  • O nome do servidor de rede ou disco rígido onde guardou o documento
  • Outras propriedades e resumo de informações ficheiro
  • Partes não visíveis de objectos OLE incorporados
  • Revisões do documento
  • Versões de documentos
  • Informações do modelo
  • Texto oculto
  • Comentários
Os metadados são criados de várias formas nos documentos do Word. Como resultado, é não único método para remover todo este conteúdo dos documentos. As secções seguintes descrevem as áreas onde podem ser guardados metadados em documentos do Word.

Este artigo descreve vários métodos que pode utilizar para minimizar metadados em documentos do Word.

A Microsoft fornece exemplos de programação apenas, para fins sem garantia expressa ou implícita. Isto inclui, mas não está limitado a, as garantias implícitas de comercialização ou adequação a um fim específico. Este artigo pressupõe que está familiarizado com a linguagem de programação apresentada e as ferramentas que são utilizadas para criar e depurar procedimentos. Os técnicos de suporte da Microsoft podem ajudar a explicar a funcionalidade de um determinado procedimento, mas não modificarão estes exemplos para proporcionarem funcionalidades adicionais nem criarão procedimentos adaptados às necessidades específicas do utilizador. Para obter mais informações sobre como utilizar o código de exemplo neste artigo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
290140  (http://support.microsoft.com/kb/290140/ ) Como executar o código de exemplo para programas do Office XP a partir de artigos da base de dados de conhecimento da Microsoft

Como remover automaticamente as informações pessoais quando guarda

Pode agora automaticamente remover informações pessoais de uma palavra do documento quando guarda o documento. Para activar esta opção, siga estes passos:
  1. No menu Ferramentas , clique em Opções .
  2. No separador segurança , clique para seleccionar a caixa de verificação Remover informações pessoais das propriedades do ficheiro guardar em Opções de privacidade e, em seguida, clique em OK .
Nota Este é o método preferencial de remover informações pessoais quando guarda um documento do Word.

Como remover manualmente o nome de utilizador dos documentos

Para ver ou alterar o nome de utilizador, siga estes passos:
  1. No menu Ferramentas , clique em Opções e clique em Informações de utilizador separador.

    Aparecem as seguintes caixas de edição:
    Nome
    Iniciais
    Endereço endereços
  2. Se pretender que destas informações apareça nos documentos, introduza cadeias não identificadoras ou espaços na caixas de edição e, em seguida, clique em OK para aceitar as alterações.
Nota Quaisquer novos documentos que criar vão contenham estas informações em vez dos valores predefinidos que são introduzidos quando instalou o Office. No entanto, documentos existentes poderão já contenham estas informações.

Como remover manualmente informações de resumo pessoais

Quando cria ou guarda um documento no Word, as informações de resumo poderão ser guardadas no documento. Existem vários métodos que pode utilizar para aceder a estas informações:
  • Abra o documento. No menu ficheiro , clique em Propriedades . Os separadores de Sumário , Estatísticas , conteúdo e Personalizar poderão conter várias propriedades como o nome, o nome do Gestor e o nome da empresa.
  • No Explorador do Windows, clique com o botão direito do rato no documento e, em seguida, clique em Propriedades . Os separadores na caixa de diálogo Propriedades poderão conter informações.
  • É possível utilizar um Microsoft Visual Basic for Applications (VBA) macro ou outro código de programa para ler as propriedades apresentadas na caixa de diálogo Propriedades .
Para limpar informações de resumo de um documento existente ou modelo, siga estes passos:
  1. Abra o documento ou modelo.
  2. No menu ficheiro , clique em Propriedades .
  3. No separador Sumário , clique para desmarcar autor , Gestor , empresa e quaisquer outras caixas de edição pretenda distribuir.
  4. No separador personalizado , elimine quaisquer propriedades que contenham informações que não pretende distribuir.
  5. Clique em OK .

    No menu ficheiro , clique em Guardar e, em seguida, clique em Fechar .
Depois de concluir estes passos, o documento não conterá propriedades de resumo.

Como remover manualmente informações de resumo pessoais quando ligado a uma rede

Se iniciada a uma rede, o nome de utilizador de rede poderá aparecer na caixa autor no separador Sumário e no campo guardado pela última vez por no separador Estatísticas quando guarda um documento. Este problema pode ocorrer mesmo se tiver removido todas as outras informações pessoais do computador.

Para remover informações de resumo de um documento quando estiver numa rede, siga estes passos:
  1. Se o documento estiver armazenado num servidor de rede, copie-o para o disco rígido local.
  2. Inicie o computador, mas efectuar não a iniciar sessão na rede. Quando vir a caixa de diálogo de início de sessão de rede, clique em ' Cancelar ' ou prima ESC.

    Nota Se não conseguir iniciar o Windows premindo a tecla ESCAPE (por exemplo, se o computador tiver o Microsoft Windows NT), não é possível concluir estes passos.
  3. Abra o documento.
  4. No menu ficheiro , clique em Propriedades .
  5. No separador Sumário , clique para desmarcar o autor , Gestor , empresa e quaisquer outras caixas de edição que contenham informações que não pretende distribuir.
  6. No separador personalizado , elimine quaisquer propriedades que contenham informações que não pretende distribuir.
  7. Clique em OK .

    No menu ficheiro , clique em Guardar e, em seguida, clique em Fechar .
Quando inicia sessão na rede, Abra o ficheiro . Se o fizer, o nome de utilizador rede poderá ser escrito no ficheiro. No entanto, pode utilizar O Explorador do Windows para copiar o ficheiro para um servidor de rede ou uma disquete.

Como remover manualmente o comentários em documentos

O Word permite adicionar comentários a documentos. Normalmente, os comentários contêm o nome da pessoa que criou isso pode indicar ao que escreveu.

Comentários aparecem normalmente como uma secção realçada de texto; pode clique com o botão direito do rato no comentário e, em seguida, clique em Eliminar comentário .

Quaisquer novos comentários criados não conter o nome de utilizador uma vez que o removeu a partir de Opções de caixa de diálogo conforme descrito na secção "Como manualmente remover o utilizador nome do documentos" deste artigo.

Como remover manualmente os cabeçalhos e rodapés de documentos

Cabeçalhos e rodapés dos documentos poderão conter informações de identificação. Para remover informações de cabeçalhos e rodapés, siga estes passos:
  1. No menu Ver , clique em cabeçalho e rodapé .
  2. O cabeçalho e rodapé aparecem na parte superior e inferior de cada página no documento.

    Alterá-las como pretende.
  3. Clique em Fechar na barra de ferramentas cabeçalho e rodapé .

Como remover manualmente o marcas de revisão

Documentos podem conter marcas de revisão. Com marcas de revisão pode determinar quem efectua alterações específicas a um documento. Quando aceitar ou rejeitar marcas de revisão, o texto revisto é guardado no documento e as marcas de revisão são removidas.

Para aceitar ou rejeitar revisões, siga estes passos:
  1. No menu Ferramentas , clique em Registar alterações para activá-la.
  2. Na barra de ferramentas Revisão , faça clique sobre anterior ou seguinte para localizar e seleccionar revisões específicas. Em seguida, clique Aceitar alteração ou Rejeitar comentário para alterar/eliminar para aceitar ou rejeitar a revisão está seleccionada.
  3. Quando tiver terminado, clique em Fechar .
Nota Se alterar as definições de "Mostrar" na barra de ferramentas Revisão, informações de revisão não são removidas.

Como desactivar a opção Fast gravação

A funcionalidade de gravação rápida aumenta a velocidade do processo de gravação de um documento, guardando apenas as alterações efectuadas num documento.

Devido à concepção da funcionalidade de gravação rápida, o texto que eliminou de um documento poderá permanecer no mesmo depois de guardar o documento. Se estiver preocupado com o texto eliminado permanecer nos documentos, siga estes passos:
  1. No menu Ferramentas , clique em Opções .
  2. Seleccione o separador Guardar .
  3. Clique para desmarcar a caixa de verificação Guardar os ficheiros rapidamente e, em seguida, clique em OK .
Para obter mais informações sobre a gravação rápida funcionalidade, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
291181  (http://support.microsoft.com/kb/291181/ ) Perguntas mais frequentes sobre "Allow Fast Saves" no Word 2002

Como procurar e remover texto que é formatado como oculto

Em documentos do Word, pode formatar texto como oculto. Uma vez que o texto oculto pode conter informações que não pretenda distribuir, poderá pretender mostrá e removê-lo. Para remover todo o texto num documento que está formatado como oculta, siga estes passos:
  1. No menu Ferramentas , clique em Opções e clique em Ver separador.
  2. Clique para seleccionar a caixa de verificação texto oculto e, em seguida, clique em OK .
  3. No menu Editar , clique em Substituir .
  4. Clique em mais para expandir a caixa de diálogo.
  5. Clique em qualquer local na caixa junto a Localizar .
  6. Clique no botão Formatar e, em seguida, clique em tipo de letra .

    Clique para seleccionar oculto e, em seguida, clique em OK .
  7. Clique em Substituir tudo .
Todo o texto oculto é removido do documento. Para desactivar a apresentação de texto oculto, siga estes passos:
  1. No menu Ferramentas , clique em Opções e clique em Ver separador.
  2. Clique para desmarcar a caixa de verificação texto oculto e, em seguida, clique em OK .

Como remover hiperligações de documentos

Documentos poderão conter hiperligações para outros documentos ou páginas Web numa intranet ou na Internet. As hiperligações são normalmente apresentadas como cadeias de texto sublinhado a azul.

Para eliminar manualmente uma única hiperligação de um documento, clique com o botão direito do rato na hiperligação, aponte para hiperligação e, em seguida, clique em Remover hiperligação .

Se pretender eliminar todas as hiperligações num documento, pode utilizar uma macro VBA para o fazer. A seguinte macro VBA de exemplo remove todas as hiperligações num documento.

Nota Na macro de exemplo seguinte, apenas a ligação é removida. O texto da hiperligação permanece no documento.

importante Antes de utilizar o seguinte exemplo de macro, reveja a exclusão de responsabilidade anteriormente neste artigo.
	Sub RemoveHyperlinks()
	
	   Dim oDoc As Document
	   Dim oStory As Range
	   Dim oHlink As Hyperlink
	
	   For Each oStory In ActiveDocument.StoryRanges
	      For Each oHlink In oStory.Hyperlinks
	         oHlink.Delete
	      Next
	   Next
	
	End Sub
para remover todos os rastreios da hiperligação e o texto da hiperligação do documento, pode utilizar a seguinte macro de exemplo em vez disso.
	Sub RemoveAllHyperlinks()
	
	   Dim oDoc As Document
	   Dim oStory As Range
	   Dim oHlink As Hyperlink
	
	   For Each oStory In ActiveDocument.StoryRanges
	      For Each oHlink In oStory.Hyperlinks
	         oHlink.Range.Delete
	      Next
	   Next
	
	End Sub

Como remover estilos de documentos

Documentos poderão incluir estilos que contenham metadados. Pode remover estes estilos ou mudar o nome dos mesmos. Para o fazer, siga estes passos:
  1. Abra o documento que contém os estilos.
  2. No menu Formatar , clique em ' estilo '.
  3. Seleccione o estilo que pretende eliminar ou mudar o nome.

    Clique em Eliminar para eliminar o estilo ou clique em Modificar para mudar o nome.

Como remover antigas versões de ficheiros de documentos

O Word inclui uma funcionalidade de versão de ficheiro que permite guardar várias versões do mesmo documento no mesmo ficheiro. Poderá eliminar versões mais antigas do documento antes de partilhar com outros utilizadores.

Para eliminar uma ou mais versões de um documento, siga estes passos:
  1. No menu ficheiro , clique em ' versões '.
  2. Seleccione a versão do documento que pretende eliminar.

    Pode seleccionar mais do que uma versão premindo a tecla CTRL enquanto selecciona as versões.
  3. Clique em Eliminar .
  4. Quando terminar de eliminação de versões antigas do documento, clique em Guardar no ficheiro menu.

Como remover ligações de códigos de campo

Imagens ligadas e outros objectos em documentos do Word poderão conter informações ligação, como o caminho do objecto ou imagem ligada. Pode remover informações de ligação do documento editando os códigos de campo.

Para apresentar códigos de campo, siga estes passos:
  1. No menu Ferramentas , clique em Opções e clique em Ver separador.
  2. Clique para seleccionar a caixa de verificação de códigos de campo e, em seguida, clique em OK .
Depois dos códigos de campo estarem visíveis, pode verificar se nenhum deles contêm informações de identificação.

Para remover as informações de ligação de uma imagem ligada ou outro objecto, siga estes passos:
  1. Seleccione a imagem ligada ou objecto ou seleccione o código de campo para a imagem ou objecto, se os códigos de campo estiverem visíveis.
  2. Prima CTRL + SHIFT + F9.
A imagem ou objecto é agora não ligados. Quando uma imagem ou objecto é não ligado, não pode editar.

Como remover o nome do modelo e a localização

Todos os documentos criados no Word baseiam-se um modelo. Por predefinição, este é o ficheiro de modelo normal.dot, localizado na pasta Modelos. No entanto, pode criar um documento baseado num modelo diferente noutra localização. O caminho e o nome deste modelo são armazenados nas propriedades do documento.

Para visualizar o nome do modelo e a localização, clique em Propriedades no menu ficheiro e, em seguida, clique no separador Resumo .

Mesmo se não enviar o modelo com o documento, o documento mantém o nome e localização do modelo. Para alterar o nome do modelo e a localização para não identificar valores, siga estes passos:
  1. No menu Ferramentas , clique em modelos e suplementos .
  2. Clique em Fechar .
  3. Seleccione um modelo que tem um nome e localização que não sejam sensíveis ou exclusivo.

    Por exemplo, uma vez que cada computador que tenha instalado o Word inclui normal.dot, poderá seleccionar Normal.dot.
  4. Clique em Abrir e, em seguida, clique em OK .
Nota Este pode conter macros, entradas de texto automático, estilos personalizados e as barras de ferramentas personalizadas. Alterando modelos, pode disponibilizar alguns destes itens ao documento.

Como remover informações da lista de distribuição

Se enviar um documento por correio electrónico utilizando uma lista de distribuição, informações de encaminhamento poderão ser anexadas ao documento. Para remover estas informações a partir do documento, tem de guardar o documento num formato que não retenha as informações do Guia de encaminhamento.

No Word, guarde o documento em formato HTML ou Rich Text Format (RTF). Feche o documento e, em seguida, reabra o novo ficheiro. Porque as informações da lista de distribuição já não está presentes, agora é possível guardar o documento no formato do Word.

Pode também seguir estes passos:
  1. Desactivar ficheiros rapidamente utilizando as instruções neste artigo.
  2. No menu ficheiro , aponte para Enviar para e, em seguida, faça clique sobre Outro destinatário da distribuição .
  3. Clique em Limpar para remover a lista de distribuição e, em seguida, clique em OK .
  4. No menu ficheiro , clique em Guardar .
O documento é guardado sem quaisquer informações da lista de distribuição.

Como remover o nome de código do Visual Basic

importante Antes de utilizar o seguinte exemplo de macro, reveja a exclusão de responsabilidade neste artigo.

Quando grava uma macro do VBA no Word, a macro gravada é iniciada por um cabeçalho semelhante ao seguinte:
	' Macro1 Macro
	' Macro recorded 3/11/1999 by <User Name>
para remover o nome de quaisquer macros gravadas, siga estes passos:
  1. Abra o documento que contém as macros.
  2. No menu Ferramentas , aponte para macro e, em seguida, clique em Editor do Visual Basic . Ou prima ALT+F11.
  3. Na janela de projecto, clique duas vezes o módulo que contém as macros.
  4. Remova o nome do código de macro gravada.
Quando terminar de remover o nome, prima ALT+Q para regressar ao programa e, em seguida, clique em Guardar no menu ficheiro .

Como remover referências do Visual Basic a outros ficheiros

No Editor do Visual Basic, pode criar uma referência a outro ficheiro. Se um utilizador abre um documento que contém referências a outros ficheiros, o utilizador pode visualizar os nomes dos ficheiros referenciados.

Para remover estas referências, siga estes passos:
  1. Abra o documento que contém referências.
  2. No menu Ferramentas , aponte para macro e, em seguida, clique em Editor do Visual Basic ou prima ALT+F11.
  3. No menu Ferramentas , clique em References .
  4. Clique para desmarcar a caixa de verificação o referido ficheiro ou ficheiros.

    Quando terminar, clique em OK .
  5. Prima ALT + Q.
  6. No menu ficheiro , clique em Guardar .
Nota Se remover referências a outros ficheiros, isto pode afectar negativamente a capacidade de macros no documento para funcionar correctamente.

Como remover informações de disco rígido ou de rede

Quando guarda um documento no disco rígido local ou num servidor de rede, as informações que identificam o disco rígido local ou o servidor de rede poderão ser escritas no documento.

Para remover estas informações a partir do documento, siga estes passos:
  1. Abra o documento.
  2. No menu ficheiro , clique em Guardar como .

    Guardar o documento para a unidade de disquetes (normalmente a unidade A).
  3. No menu ficheiro , clique em Fechar .
  4. Remova a disquete da unidade de disquetes.
Pode agora utilizar O Explorador do Windows para copiar o documento a partir da disquete para qualquer disco rígido ou servidor de rede.

Nota Devido a limitação de espaço de uma disquete (normalmente 1,44 megabytes [MB]), este método não pode ser utilizado se o tamanho de ficheiro do documento excede o espaço livre na disquete.

Objectos incorporados em documentos poderão conter metadados

Se incorporar um objecto num documento, o objecto mantém as respectivas propriedades, independentemente do que faça ao documento. Por exemplo, se incorporar um livro do Microsoft Excel no Word um documento, o documento e um livro cada tem as suas próprias propriedades.

Para remover metadados de um objecto incorporado, activar o objecto, remover quaisquer metadados conforme descrito nas secções anteriores, reactive o documento e, em seguida, guardar o documento contentor.

Nota Quando activa um objecto incorporado num documento, apenas parte do objecto incorporado é apresentada no documento; o objecto pode conter informações adicionais que não são apresentado. Se pretender que um documento contenha apenas uma representação do objecto incorporado e não o conteúdo real, utilize o comando Cortar no menu Editar para eliminar o objecto e, em seguida, utilize o comando Colar especial para colar o objecto no documento utilizando um formato de metaficheiro. Depois de o fazer, já pode editar o objecto incorporado; no entanto este não irá conterá quaisquer metadados.

Variáveis de documentos poderão conter metadados

importante Antes de utilizar a macro de exemplo seguinte, reveja a exclusão de responsabilidade neste artigo.

Para eliminar variáveis de documento contidas no documento do Word, utilize a seguinte macro de exemplo: minhavar como variável para cada
	Sub DeleteDocVars()
	
	   Dim Response
	   Dim myVar As Variable
	
	   For Each myVar In ActiveDocument.Variables
	      Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
	         "Value: " & myVar.Value & vbCr & vbCr & _
	         "Do you want to delete the variable from this document?", vbYesNo)
	            
	      If Response = "6" Then
	         ' Delete the variable.
	         myVar.Delete
	      Else
	         End
	      End If
	   Next myVar
	            
	   MsgBox "There are no variables in the document."
	   
	End Sub
Para mais informações sobre variáveis, no Editor do Visual Basic, clique em Ajuda do Microsoft Visual Basic no menu Ajuda escreva Propriedades variáveis no Assistente do Office ou no Assistente de respostas e, em seguida, clique em Procurar para visualizar o tópico.

Sugestões gerais sobre segurança

Eis algumas sugestões gerais que pode utilizar para ajudar a aumentar o nível de segurança no seu ambiente informático:
  • Quando não estiver no computador, ajuda a proteger utilizando uma protecção de ecrã protegida por palavra-passe, palavra-passe de ligação ou o Windows NT bloquear funcionalidade.
  • Se o computador tiver pastas partilhadas, certifique-se que aplica palavras-passe-lhes para que apenas utilizadores autorizados possam aceder as partilhas. Para maior segurança, utilize controlo de acesso a nível de utilizador para que possam controlar exactamente quem pode aceder às partilhas do computador.
  • Quando elimina um ficheiro, esvazie a Reciclagem imediatamente. Poderá pretender considerar um utilitário que apaga totalmente ou substitui ficheiros quando estes são eliminados.
  • Quando efectuar cópias de segurança dos dados, armazene as cópias de segurança numa localização segura, como um cofre, uma caixa de depósito de segurança ou um armário bloqueado.
  • Certifique-se que os documentos importantes são palavra-passe-protegidos para que apenas utilizadores autorizados podem abri-los. Armazenar palavras-passe numa localização segura, separada. Se não é possível recuperar uma palavra-passe, não é possível recuperar o conteúdo de um documento protegido por palavra-passe.
  • Não distribua documentos em formato electrónico. Em vez disso, imprima-as. Não utilize elementos de identificação como, por exemplo, tipos de letra característicos, marcas de água, logótipos ou papel especial, a menos que tenha (por exemplo, para uma apresentação).
  • Mensagens de correio electrónico não anónimo. Não enviar um documento se estiver preocupado com a sua identidade a ser anexada de alguma forma ao documento.
  • Não envie um documento através da Internet utilizando o protocolo de HTTP ou o protocolo de transferência de ficheiros (FTP, File Transfer Protocol). As informações enviadas através destes protocolos são enviadas em "texto simples", isto significa que é tecnicamente possível (embora improvável) para poder ser interceptadas.

A informação contida neste artigo aplica-se a:
  • Microsoft Office Word 2003
Palavras-chave: 
kbmt kbregistry kbhowtomaster KB825576 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 825576  (http://support.microsoft.com/kb/825576/en-us/ )
Partilhar
Opções de suporte adicionais
Fóruns de Suporte da Comunidade Microsoft
Contacte-nos directamente
Encontre um parceiro certificado Microsoft
Loja Microsoft