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Base de Dados de Conhecimento

Artigo: 898061 - Última revisão: quinta-feira, 11 de Outubro de 2007 - Revisão: 3.3

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importante Este artigo contém informações sobre como modificar o registo. Certifique-se uma que a cópia de segurança do registo antes de o modificar. Certifique-se que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registo do Microsoft Windows

Nesta página

Sintomas

A autenticação falha de um cliente baseado no Microsoft Windows XP se se verificarem as seguintes condições:
  • A autenticação utiliza Microsoft serviço de autenticação da Internet (IAS) num computador baseado no Microsoft Windows Server 2003.
  • A autenticação utiliza Extensible Authentication Protocol-Transport Layer Security (EAP-TLS).
  • O cliente utiliza um certificado que não contenha uma utilização de chaves de expandido (EKU).

Causa

Este problema ocorre porque a implementação actual do EAP-TLS requer a presença da autenticação do servidor EKU e a autenticação de cliente EKU do certificado pelo cliente.

Resolução

Esta correcção tem versões para Windows XP e Windows Server 2003. Para resolver o problema, siga estes passos:
  1. Aplicar a versão do Windows XP desta correcção no cliente.
  2. Aplicar a versão do Windows Server 2003 desta correcção no servidor IAS.
  3. Criar e activar a entrada de registo TlsServerUseAllPurposeCert no servidor IAS depois de aplicar as correcções.

Windows XP

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.
Pré-requisitos
Para aplicar esta correcção, tem de ter Windows XP Service Pack 2 instalado no computador. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) Como obter o Windows XP service pack mais recente
Requisito de reinício
Tem de reiniciar o computador depois de aplicar esta correcção.
Informações sobre substituição de correcções
Esta correcção não substitui quaisquer outras correcções.
Informações do ficheiro
A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item Data e hora no painel de controlo.
Windows XP, x 86 versões
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Rastls.dll5.1.2600.2719112,64014-Jul-200503: 06x 86
Arpidfix.exe5.1.2600.271930,72014-Jul-200500: 03x 86
Windows XP, versões baseadas em 64 x
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisito de SPRamo de serviço
Rastls.dll5.2.3790.2487242,68813-Jul-200512: 28x 64SP1SP1QFE
Wrastls.dll5.2.3790.2487184,32013-Jul-200512: 28x 86SP1IMPRESSIONANTE
Arpidfix.exe5.2.3790.248743,00813-Jul-200512: 28x 64NenhumNão aplicável

Windows Server 2003

aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua conta e risco.

Criar e activar a entrada de registo TlsServerUseAllPurposeCert depois de aplicar esta correcção. Para o fazer, siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Localize a seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13
  3. Com o botão direito do rato nesta subchave do registo, aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  4. Escreva TlsServerUseAllPurposeCert como o nome da entrada de registo e, em seguida, prima ENTER.
  5. Faça duplo clique na entrada de registo TlsServerUseAllPurposeCert .
  6. Na caixa de diálogo Editar valor DWORD , clique em decimal em base .
  7. Na caixa de texto dados do valor , escreva 0 ou 1 , como adequado à sua situação.

    Nota Quando este valor é definido como 1, o servidor IAS só envia ao cliente um certificado que não contenha uma EKU. Quando este valor é definido como 0, o servidor IAS só envia ao cliente um certificado que contenha uma EKU.

Informações sobre Service Packs

Para resolver este problema, obtenha o service pack mais recente do Windows Server 2003. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente do Windows Server 2003

Informações sobre a correcção

Pré-requisitos
Para aplicar esta correcção, tem de ter Windows Server 2003 Service Pack 1 (SP1) instalado no computador. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente do Windows Server 2003
Requisito de reinício
Tem de reiniciar o computador depois de aplicar esta correcção.
Informações sobre substituição de correcções
Esta correcção não substitui quaisquer outras correcções.
Informações do ficheiro
A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item Data e hora no painel de controlo.
Windows Server 2003, versões em x 86
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Rastls.dll5.2.3790.2487184,32014-Jul-200502: 49x 86
Arpidfix.exe5.2.3790.248732,25614-Jul-200501: 05x 86
Windows Server 2003, versões baseadas em Itanium
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisito de SPRamo de serviço
Rastls.dll5.2.3790.2487437,76013-Jul-200512: 28IA-64SP1SP1QFE
Wrastls.dll5.2.3790.2487184,32013-Jul-200512: 28x 86SP1IMPRESSIONANTE
Arpidfix.exe5.2.3790.248774,75213-Jul-200512: 28IA-64NenhumNão aplicável
Windows Server 2003, versões baseadas em 64 x
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisito de SPRamo de serviço
Rastls.dll5.2.3790.2487242,68813-Jul-200512: 28x 64SP1SP1QFE
Wrastls.dll5.2.3790.2487184,32013-Jul-200512: 28x 86SP1IMPRESSIONANTE
Arpidfix.exe5.2.3790.248743,00813-Jul-200512: 28x 64NenhumNão aplicável

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a". Este problema foi corrigido pela primeira vez no Windows Server 2003 Service Pack 2.

Mais Informação

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows XP Professional Edition
Palavras-chave: 
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Clique aqui para ver a versão em Inglês deste artigo: 898061  (http://support.microsoft.com/kb/898061/en-us/ )
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