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Artigo: 911149 - Última revisão: sábado, 20 de Fevereiro de 2010 - Revisão: 3.0

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Sintomas

Estiver a utilizar o Microsoft Internet Explorer num computador com o Microsoft Windows XP. Quando tenta aceder a um Web site que requer a autenticação Kerberos, poderá receber a seguinte mensagem de erro:
Erro HTTP 401 - não autorizado: Acesso negado devido a credenciais inválidas.

Causa

Este problema pode ocorrer se o Web site utilizar um registo de recursos CNAME no sistema de nomes de domínio (DNS) para contactar o servidor que inicia a autenticação Kerberos. (Este servidor emite também a permissão Kerberos.) Quando utiliza o Internet Explorer para aceder ao Web site, o Internet Explorer utiliza o nome de anfitrião do servidor em vez do registo de recursos CNAME para contactar o servidor. O processo de autenticação não funciona porque apenas o Service Principal Name (SPN) para o registo de recurso CNAME está registado na conta que é utilizada para a autenticação.

Resolução

Informações sobre a correcção

Tem uma correcção suportada disponível na Microsoft. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá ser submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de apoio a clientes da Microsoft e suporte para obter a correcção.

Nota Se ocorrerem problemas adicionais ou se for necessário efectuar algum procedimento para resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a perguntas de suporte adicionais e problemas que não são elegíveis para esta correcção específica. Para obter uma lista completa dos números de telefone do serviço de apoio a clientes da Microsoft e suporte da ou para criar um pedido de assistência separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para o qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Não existem pré-requisitos são necessários.

Requisito de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, são convertida para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador Fuso horário no item Data e hora no painel de controlo.
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisito SP
Wininet.dll6.0.2800.1545587,26406-Abr-200609: 42x 86SP1
Wininet.dll6.0.2900.2882663,55207-Abr-200604: 33x 86SP2

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo incorrectamente. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows


Depois de aplicar a actualização de software 911149, siga estes passos para activar esta actualização:
  1. Saia do Internet Explorer.
  2. Clique em Iniciar, clique em Executar, escreva regedit e, em seguida, clique em OK.
  3. Localize e, em seguida, clique na seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main
  4. No menu ' Editar ', aponte para Novo e, em seguida, clique em chave.
  5. Escreva FeatureControl e, em seguida, prima ENTER.
  6. Com a subchave de registo FeatureControl que criou no passo 5 seleccionada, aponte para Novo no menu Editar e, em seguida, clique em chave.
  7. Escreva FEATURE_USE_CNAME_FOR_SPN_KB911149 e, em seguida, prima ENTER.
  8. Com a subchave de registo FEATURE_USE_CNAME_FOR_SPN_KB911149 seleccionadas que criou no passo 7, aponte para Novo no menu Editar e, em seguida, clique em <a2>Valor DWORD.
  9. Escreva iexplore.exe e, em seguida, prima ENTER.
  10. Clique com o botão direito do rato iexplore.exe e, em seguida, clique em Modificar.
  11. Na caixa de dados, escreva 1 e, em seguida, clique em OK.

    Nota Para reverter para o comportamento anterior para retro-compatibilidade, repor este valor para 0 x 0.
  12. Sair do Editor de registo.
Nota A chave de controlo de funcionalidade FEATURE_USE_CNAME_FOR_SPN_KB911149 também pode conter outras aplicações, por exemplo:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FEATURE_USE_CNAME_FOR_SPN_KB911149\Excel.exe
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FEATURE_USE_CNAME_FOR_SPN_KB911149\Powerpnt.exe
Se existirem várias aplicações, pode adicionar uma entrada DWORD com o nome de "*" e um valor de 1 para activar esta funcionalidade para todas as aplicações instaladas que utilizem URLs.

Para obter mais informações, clique nos números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft:
326985  (http://support.microsoft.com/kb/326985/ ) Como resolver problemas relacionados com Kerberos no IIS
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 6.0 nas seguintes plataformas
    • Microsoft Windows XP Professional Edition
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbwinxpsp2fix kbwinxpsp1fix kbbug kbfix kbqfe kbpubtypekc KB911149 KbMtpt
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Clique aqui para ver a versão em Inglês deste artigo: 911149  (http://support.microsoft.com/kb/911149/en-us/ )
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