DetailPage-MSS-KB

Base de Dados de Conhecimento

Artigo: 914453 - Última revisão: sexta-feira, 1 de Junho de 2007 - Revisão: 3.4

Disponível transferência de hotfix
Ver e solicitar transferências de hotfix
 
 
importante Este artigo contém informações sobre como modificar o registo. Certifique-se de que cópia de segurança do registo antes de o modificar. Certifique-se que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registo do Microsoft Windows

Nesta página

Sintomas

Aceder a aplicações Web ou Web sites de uma Web do servidor que utiliza por segmentos transferir codificação num com o Microsoft Windows Server 2003 ou num computador baseado no Microsoft Windows XP. Em seguida, o browser ou as aplicações Web deixam de responder.

Causa

Este problema ocorre quando o ficheiro Wininet.dll recebe um segmento incompleto dos dados durante o Winsock inicial dados recebem operação. Quando este comportamento ocorre, os dados de Winsock segundo recebem operação lê apenas um token de segmento. Por exemplo, os dados de Winsock segundo receber operação pode apenas ler CR linha feed (CRLF) a partir do socket. Em seguida, o ficheiro Wininet.dll efectua chamadas contínuas para a função Seleccionar Winsock durante 30 segundos. O ficheiro está à espera para receber mais dados. No entanto, se for recebido sem dados, o browser ou aplicação Web deixa de responder.

Resolução

Windows Server 2003

Informações sobre Service Packs

Para resolver este problema, obtenha o service pack mais recente do Windows Server 2003. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente do Windows Server 2003

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.
Pré-requisitos
Não pré-requisitos são necessários.
Requisito de reinício
Tem de reiniciar o computador depois de aplicar esta correcção.
Informações sobre substituição de correcções
Esta correcção não substitui quaisquer outras correcções.
Informações do ficheiro
A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item Data e hora no painel de controlo.
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisitos do Service packRamo de serviço
Wininet.dll6.0.3790.495628,73602-Mar-200619: 15x 86NenhumRTMQFE
Wininet.dll6.0.3790.2651665,08802-Mar-200619: 24x 86SP1SP1QFE
Depois de instalar a correcção, tem de modificar o registo para activar a correcção. Para o fazer, siga estes passos: aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua conta e risco.
  1. Clique em Iniciar , clique em Executar , escreva Regedit e, em seguida, clique em OK .
  2. Para activar esta correcção por utilizador, localize e, em seguida, clique na seguinte subchave de registo:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
    Para activar esta correcção por computador, localize e, em seguida, clique na seguinte subchave de registo:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Clique a subchave de registo localizada no passo 2.
  4. No menu Editar , aponte para Novo e, em seguida, clique em chave .
  5. Escreva FEATURE_CHUNK_TIMEOUT_KB914453 e, em seguida, prima ENTER.
  6. Clique a chave de registo criado no passo 5.
  7. No menu Editar , aponte para Novo e, em seguida, clique em chave .
  8. Escreva definições e, em seguida, prima ENTER.
  9. Clique em FEATURE_CHUNK_TIMEOUT_KB914453 .
  10. No menu Editar , aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  11. Escreva iexplore.exe e, em seguida, prima ENTER.
  12. No menu Editar , clique em Modificar .
  13. Na caixa dados do valor , escreva 1 e, em seguida, clique em OK .

    Nota Os valores válidos para a subchave são 0 e 1. Um valor de 1 activa a correcção e um valor de 0 desactiva a correcção.
  14. Clique em FEATURE_CHUNK_TIMEOUT_KB914453 .
  15. Clique em definições .
  16. No menu Editar , aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  17. Escreva ChunkSelectTimeout e, em seguida, prima ENTER.
  18. No menu Editar , clique em Modificar .
  19. Na caixa dados do valor , escreva FFFFFFFF e, em seguida, clique em OK .

    Nota Os valores válidos para a subchave baseiam-se um atraso. Um valor de FFFFFFFF activa a correcção e qualquer outro valor indica o valor de limite de tempo.
  20. Saia do Editor de registo.
Nota Se actualizar a subárvore de registo HKEY_LOCAL_MACHINE, tem de reiniciar o computador. Em seguida, tem de terminar a sessão e iniciar sessão no computador para ver as alterações de comportamento.

Windows XP

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisito de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item Data e hora no painel de controlo.
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Wininet.dll6.0.2900.2859663,55201-Mar-200621: 16x 86
Depois de instalar a correcção, tem de modificar o registo para activar a correcção. Para o fazer, siga estes passos: aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua conta e risco.
  1. Clique em Iniciar , clique em Executar , escreva Regedit e, em seguida, clique em OK .
  2. Para activar esta correcção por utilizador, localize e, em seguida, clique na seguinte subchave de registo:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
    Para activar esta correcção por computador, localize e, em seguida, clique na seguinte subchave de registo:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Clique a chave de registo localizada no passo 2.
  4. No menu Editar , aponte para Novo e, em seguida, clique em chave .
  5. Escreva FEATURE_CHUNK_TIMEOUT_KB914453 e, em seguida, prima ENTER.
  6. Clique a chave de registo criado no passo 5.
  7. No menu Editar , aponte para Novo e, em seguida, clique em chave .
  8. Escreva definições e, em seguida, prima ENTER.
  9. Clique em FEATURE_CHUNK_TIMEOUT_KB914453 .
  10. No menu Editar , aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  11. Escreva iexplore.exe e, em seguida, prima ENTER.
  12. No menu Editar , clique em Modificar .
  13. Na caixa dados do valor , escreva 1 e, em seguida, clique em OK .

    Nota Os valores válidos para a subchave são 0 e 1. Um valor de 1 activa a correcção e um valor de 0 desactiva a correcção.
  14. Clique em FEATURE_CHUNK_TIMEOUT_KB914453 .
  15. Clique em definições .
  16. No menu Editar , aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  17. Escreva ChunkSelectTimeout e, em seguida, prima ENTER.
  18. No menu Editar , clique em Modificar .
  19. Na caixa dados do valor , escreva FFFFFFFF e, em seguida, clique em OK .

    Nota Os valores válidos para a subchave baseiam-se um atraso. Um valor de FFFFFFFF activa a correcção e qualquer outro valor indica o valor de limite de tempo.
  20. Saia do Editor de registo.
Nota Se actualizar a subárvore de registo HKEY_LOCAL_MACHINE, tem de reiniciar o computador. Em seguida, tem de terminar a sessão e iniciar sessão no computador para ver as alterações de comportamento.

Como contornar

Para contornar este problema, utilize uma das seguintes opções:
  • Desactive a codificação fragmentada do servidor Web. Para obter mais informações sobre se o servidor Web permite-lhe desactivar a codificação fragmentada e para obter informações sobre como desactivar a codificação fragmentada, consulte a documentação do produto de servidor Web.
  • Desactiva as definições do HTTP 1.1 no Microsoft Internet Explorer. Para o fazer, siga estes passos:
    1. Feche todas as janelas actualmente activas do Internet Explorer.
    2. Inicie o Internet Explorer.
    3. No menu Ferramentas , clique em Opções da Internet .
    4. Na caixa de diálogo Opções da Internet , clique no separador Avançadas .
    5. Em definições de HTTP 1.1 na lista definições , clique para desmarcar a caixa de verificação Utilizar HTTP 1.1.
    6. Em definições de HTTP 1.1 , clique para desmarcar a caixa de verificação Utilizar HTTP 1.1 através de ligações de proxy e, em seguida, clique em OK .

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a". Este problema foi corrigido pela primeira vez no Windows Server 2003 Service Pack 2.

Mais Informação

Para obter mais informações sobre a terminologia padrão utilizada para descrever actualizações de software da Microsoft, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows XP Professional Edition
Palavras-chave: 
kbmt kbautohotfix kbwinserv2003sp2fix kbwinserv2003presp2fix kbwinxppresp3fix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB914453 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 914453  (http://support.microsoft.com/kb/914453/en-us/ )
Partilhar
Opções de suporte adicionais
Fóruns de Suporte da Comunidade Microsoft
Contacte-nos directamente
Encontre um parceiro certificado Microsoft
Loja Microsoft