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Artigo: 925336 - Última revisão: segunda-feira, 4 de Junho de 2007 - Revisão: 3.1

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Importante: este artigo contém informações sobre como modificar o registo. Certifique-se de que cria uma cópia de segurança do registo antes de o modificar. Certifique-se de que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registo do Microsoft Windows

Nesta página

Sintomas

Quando tenta instalar um pacote do Microsoft Windows Installer (.msi) de grandes dimensões ou um pacote de patches do Microsoft Windows Installer (.msp) de grandes dimensões num computador com o Microsoft Windows Server 2003 ou o Microsoft Windows XP, recebe a seguinte mensagem de erro:
Erro 1718. O ficheiro Nome_do_ficheiro foi rejeitado pela política de assinaturas digitais.

[Error 1718. File FileName was rejected by digital signature policy.]
Além disso, poderão ser registados os seguintes eventos no registo de aplicações:
Tipo: Erro (Error)
Origem: MsiInstaller
Categoria: Nenhuma (None)
ID do evento: 1008
Data: Data
Hora: Hora
Utilizador: N/D (N/A)
Computador: Nome_do_computador

Descrição: A instalação de Nome_do_ficheiro não é permitida devido a um erro no processamento da política de restrição de software. O objecto não pode ser confiado.
[The installation of Nome_do_ficheiro is not permitted due to an error in software restriction policy processing. The object cannot be trusted.]

Causa

Este problema ocorre se o processo do Windows Installer não tiver memória virtual contígua suficiente para verificar se o pacote .msi ou .msp está correctamente assinado.

Resolução

Está disponível uma correcção para o Windows Server 2003. Não existe uma correcção disponível para o Windows XP.

Informações sobre a correcção para o Windows Server 2003

A Microsoft tem já disponível uma correcção suportada para este problema. Contudo, destina-se apenas a corrigir o problema descrito neste artigo. Aplique-a apenas em sistemas que tenham este problema específico. Esta correcção poderá ser submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, a Microsoft recomenda que aguarde pelo próximo Service Pack do Microsoft Windows Server 2003 que contenha esta correcção.

Para resolver este problema imediatamente, contacte o serviço de apoio a clientes da Microsoft para obter a correcção. Para obter uma lista completa dos números de telefone do serviço de apoio a clientes da Microsoft, bem como informações sobre os custos de suporte, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota: em casos especiais, os custos normalmente inerentes às chamadas de suporte poderão ser anulados, se um técnico de suporte da Microsoft determinar que uma actualização específica resolverá o problema. Os custos normais do suporte serão aplicados a problemas e questões de suporte adicionais, não incluídos na actualização específica em questão.Nota: transfira a correcção seguindo as instruções descritas mais adiante neste artigo.

Actualização para o Windows Server 2003 (KB925336)

O seguinte ficheiro está disponível para transferência a partir do centro de transferências da Microsoft:

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Transferir
Transferir o pacote de actualização do Windows Server 2003 (KB925336) agora. (http://www.microsoft.com/downloads/details.aspx?displaylang=pt-pt&FamilyID=8effe1d9-7224-4586-be2b-42c9ae5b9071)

Para obter mais informações sobre como transferir ficheiros de suporte da Microsoft, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
119591  (http://support.microsoft.com/kb/119591/ ) Como obter ficheiros de suporte da Microsoft a partir de serviços online
A Microsoft procedeu à detecção de vírus neste ficheiro. A Microsoft utilizou o software de detecção de vírus mais actual, disponível na data de publicação do ficheiro. O ficheiro está armazenado em servidores com segurança melhorada, que ajudam a impedir quaisquer alterações não autorizadas ao ficheiro.
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FicheiroVersãoTamanhoDataHoraPlataformaSP necessárioRamo de serviço
Advapi32.dll5.2.3790.2895620,54407-Mar-200707:05x86SP1SP1QFE
Advapi32.dll5.2.3790.4036619,00807-Mar-200707:02x86SP2SP2QFE

Actualização para o Windows Server 2003, x64 Edition (KB925336)

O seguinte ficheiro está disponível para transferência a partir do centro de transferências da Microsoft:

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Transferir
Transferir o pacote de actualização para o Windows Server 2003 x64 Edition (KB925336) agora. (http://www.microsoft.com/downloads/details.aspx?FamilyId=4BBC5917-C1AC-402C-86D9-0A8E3B9921FF)

Para obter mais informações sobre como transferir ficheiros de suporte da Microsoft, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
119591  (http://support.microsoft.com/kb/119591/ ) Como obter ficheiros de suporte da Microsoft a partir de serviços online
A Microsoft procedeu à detecção de vírus neste ficheiro. A Microsoft utilizou o software de detecção de vírus mais actual, disponível na data de publicação do ficheiro. O ficheiro está armazenado em servidores com segurança melhorada, que ajudam a impedir quaisquer alterações não autorizadas ao ficheiro.
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FicheiroVersãoTamanhoDataHoraPlataformaSP necessárioRamo de serviço
Advapi32.dll5.2.3790.28951,051,64807-Mar-200707:52x64SP1SP1QFE
Wadvapi32.dll5.2.3790.2895620,54407-Mar-200707:52x86SP1SP1QFE\WOW
Advapi32.dll5.2.3790.40361,052,16007-Mar-200716:52x64SP2SP2QFE
Wadvapi32.dll5.2.3790.4036619,00807-Mar-200716:52x86SP2SP2QFE\WOW

Actualização para o Windows Server 2003 para sistemas baseados em Itanium (KB925336)

O seguinte ficheiro está disponível para transferência a partir do centro de transferências da Microsoft:

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Transferir
Transferir o pacote da actualização para o Windows Server 2003 para sistemas baseados em Itanium (KB925336) agora. (http://www.microsoft.com/downloads/details.aspx?FamilyId=B75A5876-590F-4AC2-8063-7A04DAF6CA1A)

Para obter mais informações sobre como transferir ficheiros de suporte da Microsoft, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
119591  (http://support.microsoft.com/kb/119591/ ) Como obter ficheiros de suporte da Microsoft a partir de serviços online
A Microsoft procedeu à detecção de vírus neste ficheiro. A Microsoft utilizou o software de detecção de vírus mais actual, disponível na data de publicação do ficheiro. O ficheiro está armazenado em servidores com segurança melhorada, que ajudam a impedir quaisquer alterações não autorizadas ao ficheiro.
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FicheiroVersãoTamanhoDataHoraPlataformaSP necessárioRamo de serviço
Advapi32.dll5.2.3790.28951,481,21607-Mar-200711:42IA-64SP1SP1QFE
Wadvapi32.dll5.2.3790.2895620,54407-Mar-200711:42x86SP1SP1QFE\WOW
Advapi32.dll5.2.3790.40361,482,24007-Mar-200716:53IA-64SP2SP2QFE
Wadvapi32.dll5.2.3790.4036619,00807-Mar-200716:53x86SP2SP2QFE\WOW

Pré-requisitos

Não existem pré-requisitos.

Necessidade de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre a substituição de correcções

Esta correcção não substitui quaisquer outras.

Informações sobre os ficheiros

A versão inglesa desta correcção tem os atributos de ficheiro listados na tabela que se segue (ou atributos de ficheiro posteriores). As datas e horas destes ficheiros são indicadas no formato de hora universal coordenada (UTC, Coordinated Universal Time). Ao visualizar as informações dos ficheiros, estas serão convertidas na hora local. Para determinar a diferença entre a hora UTC e a hora local, utilize o separador Fuso horário (Time Zone) da ferramenta Data e hora (Date and Time) do Painel de controlo (Control Panel).

Como contornar

Esta medida aplica-se ao Windows Server 2003 e ao Windows XP.

Aviso: poderão ocorrer problemas graves se modificar o registo de forma incorrecta utilizando o Editor de registo (Registry Editor) ou qualquer outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. A Microsoft não garante que estes problemas possam ser resolvidos. Todo e qualquer risco decorrente da modificação do registo é da responsabilidade do utilizador.

Para contornar este problema, altere o valor de registo PolicyScope para 1 antes de tentar instalar o pacote. Para efectuar este procedimento, siga estes passos.

Nota: se o computador estiver associado a um domínio, uma actualização das políticas de domínio poderá substituir as alterações efectuadas ao registo. Recomendamos vivamente que desligue o computador do domínio antes de seguir estes passos.
  1. Clique em Iniciar (Start), clique em Executar (Run), escreva regedit e clique em OK.
  2. No Editor de registo (Registry Editor), localize e clique na seguinte chave do registo:
    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers

    Nota: antes de modificar esta chave, recomendamos que faça uma cópia de segurança da mesma. Para o fazer, clique com o botão direito do rato em CodeIdentifiers e clique em Exportar (Export). Guarde o ficheiro numa localização onde o consiga localizar no computador.
  3. Altere o valor de registo PolicyScope. Para o fazer, faça duplo clique em PolicyScope e altere a definição de 0 para 1.
  4. Feche o Editor de registo (Registry Editor).
  5. Clique em Iniciar (Start), clique em Executar (Run), escreva cmd e, em seguida, clique em OK para abrir uma janela da linha de comandos.
  6. Na linha de comandos, escreva o seguinte comando e prima ENTER:
    net stop msiserver
    Este comando pára o serviço Windows Installer se este estiver a ser executado em segundo plano. Depois de o serviço ser parado, feche a janela da linha de comandos e avance para o passo 7.

    Nota: se receber a seguinte mensagem na linha de comandos, feche a janela da linha de comandos e avance para o passo 7:
    O serviço Windows Installer não foi iniciado.
  7. Instale o pacote que estava a tentar instalar quando recebeu a mensagem de erro mencionada na secção "Sintomas".
  8. Depois de instalar o pacote, repita os passos 1 e 2. Em seguida, altere novamente o valor de registo PolicyScope novamente para 0.
  9. Se tiver desligado o computador de um domínio, volte a associá-lo ao domínio e reinicie o computador.

    Nota: se não tiver desligado o computador de um domínio, não tem de reiniciar o computador.
Se os passos anteriores não resolverem o problema, siga estes passos:
  1. Clique em Iniciar (Start), clique em Executar (Run), escreva control admintools e clique em OK.
  2. Faça duplo clique em Política de segurança local (Local Security Policy).
  3. Clique em Políticas de restrição de software (Software Restriction Policies).

    Nota: se não existirem restrições de software listadas, clique com o botão direito do rato em Políticas de restrição de software (Software Restriction Policies) e clique em Novas políticas de restrição de software (Create New Policy).
  4. Em Tipo de objecto (Object Type), faça duplo clique em Imposição (Enforcement).
  5. Clique em Todos os utilizadores menos os administradores locais (All users except local administrators) e clique em OK.
  6. Reinicie o computador.
Importante: depois de seguir os passos anteriores, os administradores locais podem instalar o pacote .msi ou o pacote .msp. Após a instalação do pacote, reponha o nível de imposição seguindo os passos anteriores. No passo 5, clique em Todos os utilizadores (All users) em vez de Todos os utilizadores menos os administradores locais (All users except local administrators).

Notas
  • Esta medida poderá não funcionar num ambiente de domínio do Active Directory. Num ambiente de domínio do Active Directory, uma operação de actualização da política de domínio substituirá as políticas de restrição de software locais.
  • Adicionar mais RAM ao computador não resolverá o problema.

Mais Informação

A partir do Microsoft Windows XP, foi introduzida uma política de segurança com o nome Políticas de restrição de software [Software Restriction Policies] (também conhecida como SAFER) para ajudar os utilizadores a evitarem executar ficheiros não seguros. O Windows Installer utiliza políticas de restrição de software para verificar as assinaturas dos ficheiros de pacotes .msi e .msp assinados. Este procedimento é efectuado pelo Windows Installer para se certificar de que os ficheiros não foram ilicitamente alterados antes de serem instalados no computador. O Windows XP e o Windows Server 2003 requerem que o ficheiro de pacote .msi ou .msp completo seja carregado num troço de memória contígua do espaço de endereçamento do processo do Windows Installer.

Se um ficheiro de pacote .msi ou .msp for demasiado grande para caber num troço de memória virtual contígua, o Windows Installer não conseguirá verificar se o pacote está correcto. Neste cenário, poderá detectar os sintomas descritos na secção "Sintomas". A correcção descrita neste artigo permite que as políticas de restrição de software utilizem menos memória virtual para efectuarem a verificação de assinatura. Assim, o Windows Installer pode verificar ficheiros de qualquer tamanho.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Professional Edition
Palavras-chave: 
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