DetailPage-MSS-KB

Base de Dados de Conhecimento

Artigo: 926047 - Última revisão: sexta-feira, 16 de Janeiro de 2015 - Revisão: 3.0

Disponível transferência de hotfix
Ver e solicitar transferências de hotfix
 
 
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Importante Este artigo contém informações sobre como modificar o registo. Certifique-se de que faça uma cópia de segurança do registo antes de o modificar. Certifique-se de que sabe como restaurar o registo se ocorrer um problema. Para mais informações sobre como efectuar cópias de segurança, restaurar e modificar o registo, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar cópias de segurança e restaurar o registo no Windows

Nesta página

Sintomas

A caixa de conclusão automática no objecto de uma iframe poderão não aparecer na localização correcta no Microsoft Internet Explorer 6.

Causa

Em alguns casos, este problema ocorre porque o valor da propriedade window.screenTop é calculado de forma incorrecta. Outro caso, se o objecto de iframe tem um estilo de posição relativa, o desvio do objecto iframe está incorrecto quando é utilizado para calcular a posição da caixa ' Conclusão automática ' .

Resolução

Windows XP

Informações sobre a correcção

Existe uma correcção suportada pela Microsoft. No entanto, esta correção destina-se apenas a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá ser submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afetado por este problema, recomendamos que aguarde pela próxima atualização de software que contenha esta correção.

Se a correcção estiver disponível para transferência, existirá uma secção de "Transferência de correcção disponível" na parte superior deste artigo da Base de dados de conhecimento. Se esta secção não for apresentada, contacte o Suporte ao Cliente da Microsoft para obter a correção.

Nota Caso ocorram problemas adicionais ou se for necessária a resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos de normais do suporte serão aplicados a questões de suporte adicional e problemas incluídos nesta correção específica. Para uma lista completa dos números de telefone de suporte e serviço de cliente da Microsoft ou para criar um pedido de assistência separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas nos quais a correcção está disponível. Se não visualizar o seu idioma, é porque uma correcção não está disponível para esse idioma.
Pré-requisitos
Tem de ter o Microsoft Windows XP Service Pack 2 (SP2) instalado para aplicar esta correcção.
Requisito de reinício
Tem de reiniciar o computador depois de aplicar esta correcção.
Informações sobre substituição da correção
Esta correcção substitui a correcção descrita no artigo 920681 da Microsoft Knowledge Base.

Informações de registo

Aviso Poderão ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. A Microsoft não garante que estes problemas possam ser resolvidos. Modificar o registo por sua conta e risco.

Depois de aplicar esta correcção, tem de adicionar e configurar um valor de registo. Para tal, siga estes passos:
  1. Clique em Iniciar, clique em Executar, tipo Regedite, em seguida, clique em OK.
  2. Localize e, em seguida, clique na seguinte chave de registo:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. No menu Editar , aponte para Novoe, em seguida, clique em chave.
  4. Tipo FEATURE_SKIP_ROW_IN_OFFSET_HEIGHT_CALCULATION_KB920681, e, em seguida, prima ENTER.

    Tenha em atenção que o nome da chave de registo não corresponde o número de artigo actual. A versão original desta correcção foi disponibilizada em correcção 920681. A correcção foi revista, em seguida, no presente artigo de Base de dados de conhecimento da Microsoft e o artigo original foi removido.
  5. No menu Editar , aponte para Novoe, em seguida, clique em Valor DWORD.
  6. Tipo Iexplore.exe, e, em seguida, prima ENTER.
  7. Iexplore.execom o botão direito e, em seguida, clique em Modificar.
  8. Tipo 1e, em seguida, clique em OK.
  9. Sair do Editor de registo.
  10. Reinicie o Internet Explorer.
Informações de ficheiro
A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são listadas na hora Universal Coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador Fuso horário no item data e hora no painel de controlo.

Windows XP com Service Pack 2 (SP2), versões baseadas em x86
Reduzir esta tabelaExpandir esta tabela
Nome do ficheiroVersão do ficheiroTamanho do ficheiroDataHoraPlataforma
Mshtml. dll6.0.2900.30093,060,73605-Out-200612:30x86

Windows Server 2003

Informações sobre Service Packs

Para resolver este problema, obtenha o service pack mais recente do Windows Server 2003. Para mais informações, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente do Windows Server 2003

Informações sobre a correcção

Para resolver este problema no Microsoft Windows Server 2003, aplique a correcção descrita no seguinte artigo da Base de dados de conhecimento da Microsoft (KB):
931306  (http://support.microsoft.com/kb/931306/ )

Ponto Da Situação

A Microsoft confirmou que este é um problema no Microsoft Internet Explorer 6. Este problema foi primeiro corrigido no Windows Server 2003 Service Pack 2.

Mais Informação

Passos para reproduzir o problema

  1. Adicione o seguinte exemplo de código para um ficheiro de texto e, em seguida, guarde o ficheiro como Top.
    <HTML>
    <BODY>
    <DIV style="POSITION: relative;">
        	<IFRAME src="TabFrame2.htm"></IFRAME>
    </DIV>
    </BODY>
    </HTML>
    
  2. Adicione o seguinte exemplo de código para um ficheiro de texto e, em seguida, guarde o ficheiro como Tabframe2.htm.
    <HTML>
    <BODY>
    <FORM>
    <INPUT  name=txtDisplayName>
    </FORM>
    </BODY>
    </HTML>
    
  3. Guarde Top e Tabframe2.htm num servidor Web.
  4. Abrir TOP, tipo Olá na caixa de texto e, em seguida, prima ENTER.
  5. Tipo h na caixa de texto.
A caixa de conclusão automática não aparece na localização correcta.
Palavras-chave: 
kbnosurvey kbarchive kbautohotfix kbwinserv2003sp2fix kbHotfixServer kbqfe kbfix kbbug kbmt KB926047 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 926047  (http://support.microsoft.com/kb/926047/en-us/ )
Partilhar
Opções de suporte adicionais
Fóruns de Suporte da Comunidade Microsoft
Contacte-nos directamente
Encontre um parceiro certificado Microsoft
Loja Microsoft