DetailPage-MSS-KB

Base de Dados de Conhecimento

Artigo: 928491 - Última revisão: quinta-feira, 15 de Novembro de 2007 - Revisão: 2.2

Disponível transferência de hotfix
Ver e solicitar transferências de hotfix
 
 
importante Este artigo contém informações sobre como modificar o registo. Certifique-se uma que a cópia de segurança do registo antes de o modificar. Certifique-se que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registo do Microsoft Windows

Nesta página

Sintomas

Quando navega de uma aplicação Web do Microsoft ASP.NET no Microsoft Internet Explorer 6, clique no botão ' Anterior ' . No entanto, o Internet Explorer não é apresentada a página Web anterior. Em vez disso, Internet Explorer incorrectamente continua a apresentar a página actual. Este problema ocorre caso se verifiquem as seguintes condições:
  • O Microsoft Windows XP Service Pack 2 (SP2).
  • O método de compressão GZIP está activado no servidor Web que hospeda a aplicação Web do ASP.NET.
  • A aplicação Web ASP.NET efectua um pedido de reposição.

Causa

Este problema ocorre porque o Internet Explorer acrescenta um cookie interno a entrada da cache da aplicação Web do ASP.NET se ocorrer um pedido de reposição. Além disso, o cookie interno é utilizado para localizar a página anterior. Se o método de compressão GZIP estiver activado, uma nova entrada de cache é acrescentada sem o cookie interno. Por conseguinte, a página anterior Impossível encontrar dentro da cache quando clica no botão ' Anterior ' .

Resolução

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Tem de ter o Microsoft Windows XP Service Pack 2 (SP2) instalado para aplicar esta correcção.

Requisito de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções que são aplicadas no computador.

Informações de registo

aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua conta e risco.

Depois de aplicar a correcção, tem de modificar definições de registo para activar a correcção. Pode modificar as definições de registo para um utilizador específico ou para todos os utilizadores.

Definições de registo para um utilizador específico

Utilize um dos seguintes métodos para activar a correcção para um utilizador específico.
Método 1
Siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique a seguinte chave no registo:
    HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\FeatureControl
  3. No menu Editar , aponte para Novo e, em seguida, clique em chave .
  4. Escreva FEATURE_URLMON_POST_DECOMPRESSION_CACHE_COOKIE_KB928491 e, em seguida, prima ENTER.
  5. No menu Editar , aponte para Novo e, em seguida, clique em Valor da cadeia .
  6. Tipo * , e, em seguida, prima ENTER.
  7. No menu Editar , clique em Modificar .
  8. Escreva 1 e, em seguida, clique em OK .
  9. No menu ficheiro , clique em Sair .
Método 2
Siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique a seguinte chave no registo:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. No menu Editar , aponte para Novo e, em seguida, clique em chave .
  4. Escreva FEATURE_URLMON_POST_DECOMPRESSION_CACHE_COOKIE_KB928491 e, em seguida, prima ENTER.
  5. No menu Editar , aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  6. Tipo * , e, em seguida, prima ENTER.
  7. No menu Editar , clique em Modificar .
  8. Escreva 1 e, em seguida, clique em OK .
  9. No menu ficheiro , clique em Sair .

Definições de registo para todos os utilizadores

Utilize um dos seguintes métodos para activar a correcção para todos os utilizadores.
Método 1
Siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique a seguinte chave no registo:
    HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\FeatureControl
  3. No menu Editar , aponte para Novo e, em seguida, clique em chave .
  4. Escreva FEATURE_URLMON_POST_DECOMPRESSION_CACHE_COOKIE_KB928491 e, em seguida, prima ENTER.
  5. No menu Editar , aponte para Novo e, em seguida, clique em Valor da cadeia .
  6. Tipo * , e, em seguida, prima ENTER.
  7. No menu Editar , clique em Modificar .
  8. Escreva 1 e, em seguida, clique em OK .
  9. No menu ficheiro , clique em Sair .
Método 2
Siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK
  2. Localize e, em seguida, clique a seguinte chave no registo:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. No menu Editar , aponte para Novo e, em seguida, clique em chave .
  4. Escreva FEATURE_URLMON_POST_DECOMPRESSION_CACHE_COOKIE_KB928491 e, em seguida, prima ENTER.
  5. No menu Editar , aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  6. Tipo * , e, em seguida, prima ENTER.
  7. No menu Editar , clique em Modificar .
  8. Escreva 1 e, em seguida, clique em OK .
  9. No menu ficheiro , clique em Sair .

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item Data e hora no painel de controlo.
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Urlmon.dll6.0.2900.3038600,06420 De Novembro de 200613: 49x 86

Como contornar

Para contornar este problema, instale o Microsoft Internet Explorer 7.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 6.0
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbpubtypekc KB928491 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 928491  (http://support.microsoft.com/kb/928491/en-us/ )
Partilhar
Opções de suporte adicionais
Fóruns de Suporte da Comunidade Microsoft
Contacte-nos directamente
Encontre um parceiro certificado Microsoft
Loja Microsoft