DetailPage-MSS-KB

Base de Dados de Conhecimento

Artigo: 936071 - Última revisão: quarta-feira, 31 de Outubro de 2007 - Revisão: 1.2

Disponível transferência de hotfix
Ver e solicitar transferências de hotfix
 
 

Nesta página

Sintomas

Considere o seguinte cenário:
  • Utilizar software de gestão de armazenamento hierárquica (HSM) para gerir ficheiros que são utilizados com pouca frequência num servidor de ficheiros. Neste caso, quando um utilizador acede a um dos ficheiros arquivados, o componente Gestor de armazenamento HSM coloca o ficheiro arquivado online. Além disso, o ficheiro arquivado é transferido para suportes de dados mais barato pelo Gestor de armazenamento de acordo com as políticas que especificar.
  • Num computador cliente baseado no Windows XP, criar uma pasta partilhada no servidor de ficheiros. Disponibilizar a pasta partilhada offline.
  • A pasta partilhada contém ficheiros que têm o atributo de ponto de reanálise .

    Nota O atributo de ponto de reanálise permanece nos ficheiros quando os ficheiros são migrados para o armazenamento offline.
  • A pasta partilhada foi sincronizada com o servidor de ficheiros e ficheiros arquivados foram transferidos para a cache offline dos computadores cliente na rede.
  • Num computador cliente baseado no Windows XP na rede, o utilizador tenta abrir um documento numa partilha de rede utilizando uma aplicação do Microsoft Office quando trabalha offline.
Neste cenário, não é possível abrir o documento como previsto. Além disso, poderá receber uma mensagem de erro. Por exemplo, no Microsoft Word, poderá receber uma mensagem de erro semelhante à seguinte:
Erro ao abrir o ficheiro.
No Microsoft Excel, poderá receber uma mensagem de erro semelhante à seguinte:
Não é possível Access file_name

Causa

Quando exclusivo de bloqueio oportunista está disponível num ficheiro, o componente Mrxsmb coloca em cache determinados pedidos, tais como pedidos de leitura, pedidos de escrita, os pedidos lock e pedidos de aberto. Este comportamento de colocação em cache torna os pedidos interno. Por conseguinte, estes pedidos só são enviados através da rede.

Quando o componente Mrxsmb recebe um pedido de bloqueio, o componente Mrxsmb verifica se existe um conflito de bloqueio localmente. Por exemplo, o componente Mrxsmb verifica se o ficheiro é aberto por outras aplicações, independentemente do bloqueio de memória intermédia de estado.

No Windows XP, os processos de componente Mrxsmb requisições de leitura apenas para ficheiros dispersos. Todos os outros pedidos são enviados para o servidor de ficheiros. (Isto inclui os pedidos lock.) Por conseguinte, quando o cliente estiver offline, não consegue abrir o ficheiro.

Resolução

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Para instalar esta correcção, tem de ter Windows XP Service Pack 2 instalado.

Requisito de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções disponibilizadas anteriormente.

Informações de registo

Para utilizar esta correcção, não é necessário efectuar alterações ao registo.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item data e hora no painel de controlo.
Windows XP com SP2, x 86 versões
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Mrxsmb.sys5.1.2600.3235454,78416 De Outubro de 200712: 44x 86

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional Edition
Palavras-chave: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB936071 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 936071  (http://support.microsoft.com/kb/936071/en-us/ )
Partilhar
Opções de suporte adicionais
Fóruns de Suporte da Comunidade Microsoft
Contacte-nos directamente
Encontre um parceiro certificado Microsoft
Loja Microsoft