DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 947195 - Última revisão: segunda-feira, 14 de abril de 2008 - Revisão: 2.1

 

Nesta página

Sintomas

Considere o seguinte cenário:
  • Desenvolver uma página da Web que usa compactação Gzip HTTP ou compactação HTTP Desinflar.
  • A página da Web está hospedada em um servidor que usa compactação Gzip ou Deflate.
  • Usar o Microsoft Internet Explorer 6 para procurar as páginas da Web estritas XHTML em um computador que está executando o Windows XP Service Pack 2 (SP2).
Nesse cenário, Internet Explorer não exibe as páginas da Web estritas XHTML corretamente.

Esse problema ocorre se um ou mais das seguintes condições forem verdadeiras:
  • O tamanho do cabeçalho HTTP é muito grande.
  • Carga de trabalho do computador é alta.

Causa

Esse problema ocorre porque, quando a compactação Gzip ou Deflate é usada pelo Internet Explorer 6 em um computador com Windows XP SP2, o Internet Explorer 6 pode tentar determinar o tipo MIME de um documento XHTML antes do Internet Explorer 6 recebe dados suficientes para distinguir entre XML e XHTML.

Se a primeira parte do conteúdo do corpo que recebe do Internet Explorer 6 contém apenas conteúdo XML, a determinação de MIME pode informar que o documento é "text/xml"em vez de"text/html" Portanto, o Internet Explorer não exibe a página XHTML corretamente.

Resolução

Informações de atualização de segurança

Para resolver esse problema, instale a actualização de segurança cumulativa mais recente para o Internet Explorer. Para instalar as atualizações mais recentes, visite o seguinte site:
http://windowsupdate.microsoft.com (http://windowsupdate.microsoft.com)
Para informações mais técnicas sobre a atualização de segurança cumulativa mais atual para o Internet Explorer, visite o seguinte site:
http://www.microsoft.com/technet/security/current.aspx (http://www.microsoft.com/technet/security/current.aspx)
Observação Essa correção primeiro foi incluída na atualização de segurança 947864 (MS08-024). Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
947864  (http://support.microsoft.com/kb/947864/ ) MS08-024: Actualização de segurança cumulativa para Internet Explorer


Informações sobre o hotfix

Pré-requisitos

Você deve ter o Windows XP SP2 instalado no computador.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações do registro

Depois de aplicar esse hotfix, você deve habilitar o hotfix. Para fazer isso, siga estas etapas.

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows
  1. Clique em Iniciar , clique em Executar , digite regedit na caixa Abrir e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. No menu Editar , aponte para novo e, em seguida, clique em chave .
  4. Digite o seguinte nome e, em seguida, pressione ENTER:
    FEATURE_COMPRESSED_XHTML_USE_CONTENT_TYPE_KB947195
  5. No menu Editar , aponte para novo e, em seguida, clique em valor DWORD .
  6. Digite iexplore.exe e, em seguida, pressione ENTER .

    Observação Se desejar habilitar um aplicativo diferente do Internet Explorer usar esse hotfix, digite o nome do aplicativo em vez de "iexplore.exe".
  7. No menu Editar , clique em Modificar .
  8. Digite 1 e, em seguida, clique em OK .
  9. Feche o Editor do Registro.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows XP com SP2, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Urlmon.dll6.0.2900.3297618,49621 De janeiro de 200811: 42x 86

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre XHTML, visite os seguintes sites:
http://www.w3.org/TR/xhtml-basic/ (http://www.w3.org/TR/xhtml-basic/)
http://www.w3.org/TR/xhtml1/ (http://www.w3.org/TR/xhtml1/)
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
255801  (http://support.microsoft.com/kb/255801/ ) Como determinar se a compactação de HTTP está em uso
Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 6.0
Palavras-chave: 
kbmt atdownload kbexpertiseadvanced kbfix kbpubtypekc kbqfe KB947195 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 947195  (http://support.microsoft.com/kb/947195/en-us/ )
Partilhar
Opções de suporte adicionais
Fóruns de Suporte da Comunidade Microsoft
Contacte-nos directamente
Encontre um parceiro certificado Microsoft
Loja Microsoft