DetailPage-MSS-KB

Base de Dados de Conhecimento

Artigo: 958046 - Última revisão: domingo, 9 de Fevereiro de 2014 - Revisão: 2.0

 

Nesta página

Sintomas

Quando tenta ligar ao site Windows Update ou Microsoft Update da Web, recebe o seguinte código de erro:
0X80248007

Causa

Este problema ocorre uma das seguintes razões:
  • Windows Update ou Microsoft Update determina que existe falta de dados no arquivo de dados do Microsoft Windows Update.
  • Windows Update ou Microsoft Update não consegue localizar os termos de licenciamento de Software Microsoft.

Resolução

Para resolver o problema, utilize os seguintes métodos pela ordem em que são apresentados.

Método 1: Mudar o nome da pasta de transferência temporária do Windows Update

Para mudar o nome da pasta de transferência temporária do Windows Update, siga os passos adequados para o sistema operativo.

Importante Depois de mudar o nome de pasta de transferência temporária, actualizações que já transferiu mas que ainda não tiver instalado tem de ser transferidas novamente do Windows Update ou do Microsoft Update.

No Windows XP, no Windows Server 2003 e no Windows 2000, siga estes passos:
  1. Inicie o bloco de notas. Para tal, clique em Iniciare, em seguida, clique em Executar.
  2. Copiar e, em seguida, cole (ou escreva) o seguinte comando na caixa Abrir e, em seguida, prima INTRODUZA:
    Bloco de notas
  3. Copie e cole (ou escreva) as seguintes linhas de comando para a janela de bloco de notas:
    net stop wuauserv
    CD %systemroot%\SoftwareDistribution
    ren Download.old transferir
    net start wuauserv
  4. No menu ficheiro , clique em Guardar comoe, em seguida, escreva Rename.bat.
  5. Clique em Guardar como tipoe, em seguida, clique em Todos os ficheiros.
  6. Guarde o ficheiro de Rename.bat no ambiente de trabalho.
  7. Faça duplo clique no ficheiro Rename.bat para mudar o nome da pasta de transferência.
  8. Tente instalar novamente actualizações.
  9. Se o problema for resolvido, elimine o ficheiro de Rename.bat que criou nos passos anteriores.
Se o problema ainda não for resolvido, avance para o método 2.

Nota Depois pode transferir e instalar actualizações com êxito, pode eliminar a pasta Download.old para recuperar espaço em disco.

No Windows Vista e no Windows Server 2008, siga estes passos:
  1. Clique em Iniciar
    Reduzir esta imagemExpandir esta imagem
     Botão Iniciar
    e, em seguida, escreva Bloco de notas na caixa Iniciar procura .
  2. Na lista de programas , clique em Bloco de notas.
  3. Copie e cole (ou escreva) as seguintes linhas de comando para a janela de bloco de notas:
    net stop wuauserv
    CD %systemroot%\SoftwareDistribution
    ren Download.old transferir
    net start wuauserv
  4. No menu ficheiro , clique em Guardar comoe, em seguida, escreva Rename.bat.
  5. Clique em Guardar como tipoe, em seguida, clique em todos os ficheiros (*. *).
  6. Guarde o ficheiro de Rename.bat no ambiente de trabalho.
  7. Botão direito no ficheiro Rename.bat e, em seguida, clique em Executar como administrador.
    Reduzir esta imagemExpandir esta imagem
    Permissão de controlo de conta de utilizador
    Se lhe for pedido para uma palavra-passe de administrador ou confirmação, escreva a palavra-passe ou clique em continuar. Muda o nome da pasta de transferência.
  8. Tente instalar novamente actualizações.
  9. Se o problema for resolvido, elimine o ficheiro de Rename.bat que criou nos passos anteriores.
Se o problema ainda não for resolvido, avance para o método 2.

Nota Depois pode transferir e instalar actualizações com êxito, pode eliminar a pasta Download.old para recuperar espaço em disco.

Método 2: Mudar o nome de pasta SoftwareDistribution de actualização do Windows

Para mudar o nome da pasta SoftwareDistribution temporária do Windows Update, siga os passos adequados para o sistema operativo.

Importante As seguintes acções são afectadas quando executa o método 2:
  • Actualizações que já transferiu mas que ainda não tiver instalado tem de ser transferidas novamente do Windows Update ou do Microsoft Update.
  • Ao eliminar a pasta SoftwareDistribution, irá remover o histórico de transferências.
Se actualmente receber actualizações do Microsoft Update e do Windows Update, tem de seleccionar novamente esta opção do Windows Update. Para tal, siga estes passos:
  1. Visite o seguinte Web site Windows Update:
    http://www.Update.microsoft.com/windowsupdate (http://www.update.microsoft.com/windowsupdate)
  2. No ecrã Bem-vindo ao Windows Update , junto a Obter hoje a actualização do Microsoft, clique em Ir.
  3. Siga no ecrã instruções sobre como configurar o Microsoft Update para executar no computador.
No Windows XP, no Windows Server 2003 e no Windows 2000, siga estes passos:
  1. Inicie o bloco de notas. Para tal, clique em Iniciare, em seguida, clique em Executar.
  2. Copiar e, em seguida, cole (ou escreva) o seguinte comando na caixa Abrir e, em seguida, prima INTRODUZA:
    Bloco de notas
  3. Copie e cole (ou escreva) as seguintes linhas de comando para a janela de bloco de notas.
    net stop wuauserv
    CD % systemroot %
    ren SoftwareDistribution SoftwareDistribution
    net start wuauserv
  4. No menu ficheiro , clique em Guardar comoe, em seguida, escreva Rename.bat.
  5. Clique em Guardar como tipoe, em seguida, clique em Todos os ficheiros.
  6. Guarde o ficheiro de Rename.bat no ambiente de trabalho.
  7. Faça duplo clique no ficheiro Rename.bat para mudar o nome da pasta SoftwareDistribution.
  8. Tente instalar novamente actualizações.
  9. Se o problema for resolvido, elimine o ficheiro de Rename.bat que criou nos passos anteriores.
Nota Depois pode transferir e instalar actualizações com êxito, pode eliminar a pasta SoftwareDistribution para recuperar espaço em disco.

No Windows Vista e no Windows Server 2008, siga estes passos:
  1. Clique em Iniciar
    Reduzir esta imagemExpandir esta imagem
     Botão Iniciar
    e, em seguida, escreva Bloco de notas na caixa Iniciar procura .
  2. Na lista de programas , clique em Bloco de notas.
  3. Copie e cole (ou escreva) os seguintes comandos para a janela de bloco de notas.
    net stop wuauserv
    CD % systemroot %
    ren SoftwareDistribution SoftwareDistribution
    net start wuauserv
  4. No menu ficheiro , clique em Guardar comoe, em seguida, escreva Rename.bat.
  5. Clique em Guardar como tipoe, em seguida, clique em todos os ficheiros (*. *).
  6. Guarde o ficheiro de Rename.bat no ambiente de trabalho.
  7. Botão direito no ficheiro Rename.bat e, em seguida, clique em Executar como administrador.
    Reduzir esta imagemExpandir esta imagem
    Permissão de controlo de conta de utilizador
    Se lhe for pedido para uma palavra-passe de administrador ou confirmação, escreva a palavra-passe ou clique em continuar. Muda o nome da pasta SoftwareDistribution.
  8. Tente instalar novamente actualizações.
  9. Se o problema for resolvido, elimine o ficheiro de Rename.bat que criou nos passos anteriores.
Nota Depois pode transferir e instalar actualizações com êxito, pode eliminar a pasta SoftwareDistribution para recuperar espaço em disco.

A informação contida neste artigo aplica-se a:
  • Microsoft Update
  • Microsoft Windows Update
Palavras-chave: 
kbupdateissue kbexpertisebeginner kbtshoot kberrmsg kbprb kbmt KB958046 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 958046  (http://support.microsoft.com/kb/958046/en-us/ )
Partilhar
Opções de suporte adicionais
Fóruns de Suporte da Comunidade Microsoft
Contacte-nos directamente
Encontre um parceiro certificado Microsoft
Loja Microsoft