DetailPage-MSS-KB

知识库

文章编号: 323153 - 最后修改: 2007年2月21日 - 修订: 2.8

 
 

本页

症状

上一条电缆的两个 IDE 驱动器的计算机可能停止响应 (挂起),当计算机从待机状态恢复时。

原因

IDE 磁盘驱动程序不会重置驱动器之前检查驱动器状态在繁忙的位。这将创建使用等待状态的 S3 休眠状态的计算机的问题。此状态到驱动器,而不是发出到 S2 待机状态中驱动器的休眠命令剪切电源。 这会导致重置之前驱动器协商完成该驱动器重新启动时驱动器。ATAPI 的指定驱动器调用重置驱动器之前检查忙碌位。规范也指出驱动器忽略重置,直到该驱动器是同步并且准备好运行后协商。当前销售某些驱动器不要执行此操作。 这会导致计算机出现两个驱动器来启动与对编程,以将导致计算机挂起相同的电缆上主控形状的两个驱动器。

解决方案

服务包信息

若要解决此问题,获得最新的 service pack,对于 Microsoft Windows 2000。有关更多的信息请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
260910  (http://support.microsoft.com/kb/260910/EN-US/ ) 如何获取最新的 Windows 2000 服务软件包

修复程序信息

可以从 Microsoft 获得支持的修补程序。但是,此修补程序被用于解决本文所述的此问题。此修补程序仅应用于出现这一特定问题的系统。

是否可供下载此修补程序没有"提供修补程序下载"部分中,在这篇知识库文章的顶部。如果未出现本部分,将申请提交到 Microsoft 客户服务和支持以获取此修复程序。

注意如果出现其他问题,或者如果需要进行任何故障诊断,则您可能不得不创建单独的服务请求。将正常收取支持费用将应用于其他支持问题和不需要进行此特定的修补程序的问题。有关完整列表的 Microsoft 客户服务和支持的电话号码,或创建一个单独的服务请求,请访问下面的 Microsoft 网站:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
注意"提供修补程序下载"窗体所显示的此修复程序是可用的语言。如果您看不到您的语言,则是一个修复程序不能用于该语言。此修复程序的英文版具有文件属性 (或更高版本) 下表中列出。其格式为协调通用时间 (UTC) 列出日期和时间对这些文件。当您查看文件信息时,将转换为本地时间。 若要 UTC 与本地时间之间的时差使用控制面板中的日期和时间工具中的 时区 选项卡。
   Date         Time   Version        Size    File name
   ----------------------------------------------------
   09-May-2002  10:45  5.0.2195.5762  86,896  Atapi.sys
				

状态

Microsoft 已经确认这是在本文开头列出的 Microsoft 产品中的问题。 在 Microsoft Windows 2000 Service Pack 4 中,第一次已得到纠正此问题。

更多信息

有关如何获得 Windows 2000 数据中心服务器修补程序的其他信息请单击下面文章编号,以查看 Microsoft 知识库中相应的文章:
265173  (http://support.microsoft.com/kb/265173/EN-US/ ) 数据中心计划和 Windows 2000 数据中心服务器产品
有关如何在只重新启动一次的情况下安装多个修补程序的其他信息请单击下面文章编号,以查看 Microsoft 知识库中相应的文章:
296861  (http://support.microsoft.com/kb/296861/EN-US/ ) 使用 QChain.exe 与一个重新启动安装多个修补程序

这篇文章中的信息适用于:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
关键字: 
kbmt kbautohotfix kbhotfixserver kbqfe kboswin2000fix kbwin2ksp4fix kbbug kbfix kbwin2000presp4fix KB323153 KbMtzh
机器翻译机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 323153  (http://support.microsoft.com/kb/323153/en-us/ )
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。
其他支持选项
Microsoft Community 支持论坛
直接联系我们
查找 Microsoft 认证合作伙伴
Microsoft 商店